GM Truck Club Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hello I'm new to this site. I recently bought a 1988 Chevy Silverado w/ 5.7 350 3 speed. Engine has 120,000 miles and was taken care of (driven by older couple). Oil was changed regularly and looks clean on dip stick. I have only had it for couple weeks. Recently drove about 20 miles and when came to stop sign with clutch pushed in got check engine light. Looked at gauges and oil pressure was at about 10, when driving down road light goes away when oil pressure rises to about 15-20. Engine does not get overheated, not knocking, idles well. Should I try using a higher weight oil like 10w-40 or go right to changing oil pump. I hope its not bearings but how would I be able to tell? It gets cold here in iowa and also wnder if heavier oil couold mean harder starts this winter. I forgot to mention that start up oil pressure is around 30. Stays that way until temp goes up.
Thanks.
 

·
Registered
Joined
·
2,428 Posts
Yes, try a higher weight oil. Don't worry, during colder weather the pressure will be higher so switching to a lower weight oil during the winter would work, but I don't think that will be a problem for you.

Also make sure your idle speed is correct. Too low and it can drop your pressure into the red zone.

You can also use a viscosity improver, like STP. Remember all those Andy Granatelli commercials?
 

·
Administrator
Joined
·
649 Posts
That's low miles for an '88, averaging under 5,500 per year. No knocking or pinging at all? If you've not done an oil change on this vehicle since you got it, I would recommend that you start with that and see what you've got coming out. There could be a low viscocity or a synthetic in there and it's always nice to get it changed so you know what you're dealing with when you start one of these searches for parts to replace. I've sometimes seen something as simple as a bad gauge or something else that's pretty simple to fix.
 

·
Registered
Joined
·
39 Posts
I've seen this symptom with a weak oil pressure switch (located at the back of the block near the intake) before. I'm betting on this instead of major problems or oil problems. Usually just a few dollars at your local parts store.

Jim
:glasses:
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Thanks all. Will start with oil change and use 10w-40. Might also purchase addative to thicken vescosity. After that will look into switches and gauges before going to pump. It doesn't knock at all and no lifter noise either so am hoping for the best. Got a great deal on this truck It was well taken care of. Paid 1k for it!
 

·
Registered
Joined
·
3,438 Posts
Lots of older vehicles, regardless of mileage, will lose oil pressure a bit over time. As long as it doesnt knock, overheat or consume oil you are fine. But for the piece of mind (just like I did) you might want to switch to a heavier oil.
 

·
Registered
Joined
·
63 Posts
LOW Oil pressure

I had the same problem with my 88. I replaced the oil sending unit behind the distributor and it didn't help. Then, I found out there's a second oil sending unit accessible from beneath the vehicle. Strange! Can anyone confirm this?:neutral:
 

·
Registered
Joined
·
3,438 Posts
The oil pump inside the pan is not easy to get too,(if you have 4x4), you have to remove the front drive shaft and if you have factory oil coolant lines it makes it that much harder to drop the pan.
 

·
Registered
Joined
·
63 Posts
Oil Sending Unit

I replaced both of the oil sending devices (wherever they are) and the Chevy guys put a manual oil pressure guage on it and said my oil pressure was well within factory specs for that year. It was only 25 pounds at idle and 30 at higher RPM. When I replaced both sending units, the check engine light never relit.
 

·
Registered
Joined
·
39 Posts
Glad to hear it. This has been my experience more times than not. Have fun!:great:
 

·
Registered
Joined
·
7 Posts
Discussion Starter #12
I replaced both of the oil sending devices (wherever they are) and the Chevy guys put a manual oil pressure guage on it and said my oil pressure was well within factory specs for that year. It was only 25 pounds at idle and 30 at higher RPM. When I replaced both sending units, the check engine light never relit.
Where were they located-the sending units?
 

·
Registered
Joined
·
2 Posts
Oil Sending Unit

I replaced both of the oil sending devices (wherever they are) and the Chevy guys put a manual oil pressure guage on it and said my oil pressure was well within factory specs for that year. It was only 25 pounds at idle and 30 at higher RPM. When I replaced both sending units, the check engine light never relit.
 

·
Registered
Joined
·
2 Posts
Mine is doing the same thing it starts at about 25 pounds and idle and 30 pounds at higher rpm but mine dont like climbing hills too much and over heats for a min but goes back down to normal. A few days ago oil pressure gauge would read at 60 pounds at start up until it warmed up and would drop down to around 45-55 pounds and would stay there.
 
1 - 14 of 14 Posts
Top