GM Truck Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Hi again, Im really having some problems with my 91 silverado 305TBI/auto 128k always kept in excellent condition. Well I am having a problem with it just quitting after a 5/6mile jog around town came into my drive way and it just quit, tried to restart and just cranked and cranked no start. It was running like a top just before it stopping, this happen twice before and had to have it towed home,(thank god for AAA) so here is what I've done.
New fuel pump, Fp relay, rebuilt the Troddle body, fuel filter, and new plugs. It runs like a top just until it stopped. Someone said that this happen to there silverado and they found they had a bad ignition module. Now does this sound like a ignition module could be causing this problem? Ive been around cars/trucks for a very long time and this is really getting me down, Im going to check the fuel pressure tomorrow and see what happens, thanks for any help or suggestions.
 

·
Registered
Joined
·
7,979 Posts
Sounds like it could be the ignition module.. but i would troubleshoot it.. also do you have a check engine light on??
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
I just went out to the truck and it started right up, it has been sitting for about a hour, this is the 3rd time the exact thing has taken place. When the truck quits I listen for the fuel pump, no sound, after about a hour or so it starts working again and the truck starts up. Could the ignition module be getting hot and breakin g down? No check engine light and no codes showing up, what the heck!!
 

·
Registered
Joined
·
7,979 Posts
Sounds like you will want to take and swap over the Fuel Pump relay with a cold one the next time it does it.. if it starts then you have a problem with the Fuel Pump wiring. and if it doesnt run still then you have an issue with the ignition module.
 
1 - 5 of 5 Posts
Top