GM Truck Club Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Premium Member
Joined
·
1,625 Posts
Discussion Starter #1
94 GMC Burb, 199,000 miles, 350 TBI, Just did head gaskets this spring, new fuel pump this past spring, new fuel filter 2 months ago, New plugs, wires, this summer.


My wife left this morning at 7:30 AM this morning, at 8 AM she called from a gas station 10 miles away.

She had filled the tank, (Great now I have 41 Gallons of gas in it).

After filling the tank it would not start.

So I drove down to where she was in the Fiero, sprayed a very quick short burst of starting fluid in the throttle body, half expecting it to fire and then die.

To my surprise it not only fired but stayed running.

So I had her drive it home where she shut it off in the driveway, and it wouldn’t start again.

So I cleaned out the garage, half expecting to have to push the truck in. To my surprise after another short squirt of starting fluid the truck started again and drove into the garage under it’s own power.

Now I just this spring put a new fuel Pump in and had checked the fuel pressure no more than a week ago because of a rough running engine. It was 13 lbs solid.

It was in the garage today and I checked for spark, it was getting it (obviously).

I checked for fuel, it’s getting fuel to the pressure regulator, just before the twin injectors.

Just replaced the water temp sensor today on the off chance it had something to do with it.

Checked for electrical pulse at the injectors, no pulse.

I Quit screwing with it around 1 PM today because I was getting pissed.

Now I am leaning to 1 of 2 things.

Pressure regulator.

Or

Ignition Module.

Nether of which is real expensive, both under 50 bucks each.

I hate technology, give me a carbureted engine any day.

Any Ideas?
 

·
Administrator
Joined
·
4,886 Posts
RE: 94 Burban won’t start

It's not getting enough fuel on start. Hang on, my son is jumping on me...
 

·
Premium Member
Joined
·
1,625 Posts
Discussion Starter #3
RE: 94 Burban won’t start

LOL

NO Kidding, why, and better yet what is the cause. Pressure reg, or ignition module?

Smart aleck.
 

·
Administrator
Joined
·
4,886 Posts
RE: 94 Burban won’t start

My 26 month old was jumping on me, I swear that kid's as strong as a 5 year old.

Anyhow, I've never had it where the car will run and stay running after providing a blast of starting fluid. If it were the ignition module, why would it start better with the starting fluid? More combustible? You mentioned that it was running rough last week or so, any cause for that?
 

·
Premium Member
Joined
·
1,625 Posts
Discussion Starter #5
RE: 94 Burban won’t start

loose plug wire, found it and she ran fine.

Hang on my wife is breathing heavey in my ear...
 

·
Premium Member
Joined
·
1,625 Posts
Discussion Starter #7
Re: RE: 94 Burban won’t start

TrailLeadr said:
84fiero123 said:
loose plug wire, found it and she ran fine.
Hang on my wife is breathing heavy in my ear...
This is why I come back to the site day after day...Just for the witty remarks... :D :D :D
lol
Found the problem, believe it or not it was the ignition module.

Never had one do that, I’ve heard of them going but never like this. When ever I have had them go they just go.

So she is back running.

Hang on now the wife is doing more than just breathing heavy in my ear…………….
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top