GM Truck Club Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
1997 GMC K1500. Stopped running while being driven. The fuel pump was changed, there is 58 lbs fuel pressure but will not start unless you pour gas in the throttle body. The pressure holds and does not leak off, the spider was changed 2 1/2 years ago. After the pump was changed it started, taken for a drive, shut off and it restarted. Sat overnight, would not start this morning unless primed. Any suggestions on where to look, I am thinking it is probably some kind of sensor issue?
 

·
Super Moderator
Joined
·
1,591 Posts
How confident are you in your pressure gauge? I know I had troubles with my '98 that ended up being the fuel pump. The main diagnostic symptom was that the fuel pressure would never get about about 55 psi. These engines are awful sensitive to fuel pressure/fuel delivery issues. I would try cycling the key on and off a couple of times or powering the fuel pump test lead or something to verify that 58 psi is the max pressure available. If so, I would begin to suspect something in fuel delivery (pumps are common).
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
How confident are you in your pressure gauge? I know I had troubles with my '98 that ended up being the fuel pump. The main diagnostic symptom was that the fuel pressure would never get about about 55 psi. These engines are awful sensitive to fuel pressure/fuel delivery issues. I would try cycling the key on and off a couple of times or powering the fuel pump test lead or something to verify that 58 psi is the max pressure available. If so, I would begin to suspect something in fuel delivery (pumps are common).
Thanks, but the pump was replaced first. My husband is a mechanic and is sure about the pressure.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
How confident are you in your pressure gauge? I know I had troubles with my '98 that ended up being the fuel pump. The main diagnostic symptom was that the fuel pressure would never get about about 55 psi. These engines are awful sensitive to fuel pressure/fuel delivery issues. I would try cycling the key on and off a couple of times or powering the fuel pump test lead or something to verify that 58 psi is the max pressure available. If so, I would begin to suspect something in fuel delivery (pumps are common).
It is a brand new fuel pump, just installed. When it is primed it will start. The book says it should have a minimum pressure of 60. If the fuel pressure is low why would it run after it has been primed manually? Hubby is trying to figure out if it is that the new pump is no good.
 

·
Super Moderator
Joined
·
1,591 Posts
I would naturally defer to the mechanic's opinion as he is the one there with the vehicle in front of him. I also agree with the possibility of a bad, new pump. I know when the factory pump went out on my '98, the first pump I replaced it with only lasted 2 or 3 months, until it would no longer generate enough pressure (it seems to be a common scenario, especially with aftermarket, non-ACDelco pumps). I expect that the reason it runs once started is because it is easier to stay running than to start.

Your husband has the vehicle there, so he can test what needs testing. If I had a late '90's Vortec engine where the pump could not generate a pressure above 60 psi, I would at least be suspicious that the pump is the problem.
 

·
Registered
Joined
·
3 Posts
I agree with shorty been gm master teck for 30 years now , I have seen 1 or 2 pounds of fuel pressure make or break a fuel system the first and second vortex fuel systems were VERY SENSITIVE!!! OF course this is my opinion .
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Thanks for the comments and ideas. Turns out it was the new pump. Pulled it out, put another new pump in and everything works again. You just never know, you wouldn’t expect the problem to be the new part.
 
1 - 7 of 7 Posts
Top