GM Truck Club Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
ok I have a 99 chevy silverado
-4.3 liter V6
-AUTO tranny
-140333 milage
-was sitting for almost 2 years
- had the part of the block where the starter bolts on welded and a new hole drilled and tapped, because it was broken off
-just drove it from lousianna to colorado begenning of this month.
-the oil and tranny fluid, fuel filterand oil filter were changed prior to the drive to colorado
-spark plug wires are a year old but wern't driven on since i drove it to colorado
-changed the spark plugs yesterday.
-my ABS light, Brake light, and engine light are all on.

Its been running pretty decent given the time it sat.
its been starting up pretty bad since i got it running, but the last coulple of days its been really hard to start.
this morning it took me holding the key for about 1 1/2 min, the first time nuthing happened, then i held it down for about another 1 1/2 min. and it finally started.

any help would be appreciated.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
well i just found out today that I can get the codes read at the auto craft shop on post "which is a on post garage where you can work on your vehical"
and ya i kinda figured i had more than 1 problem I was trying to see if any of these has happened to someone before because it could be 1 of many differant things.

also I forgot to put in there the engine light has been on since i had the truck over 3 years ago, when it ran like a kitten.

also the gas gage hasnt worked since i had it.
it will randomly bounce from full to empty and never tells the right thing.

any ideas "I'm not to worried about that cuz its just a nuisence problem but still if its a inexspencive fix then i'll fix it."
 
1 - 2 of 2 Posts
Top