GM Truck Club Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter #1
Lets start off with the.... The ole lady was drivin the burban yesterday and she parked it and it died. Now i know that everyone says do a major tune up. Well it has new Accel U groove plugs, 8mm wires. Jegs red hot coil, air induction kit. I have no idea other the poss. fuel filter. any other ideas?

Next rough idle when u first start. smooths out after it warms up. Any ideas?

Last i am in need of a "Y" pipe. they do not make a aftermarket one. Is this a dealer only item? Or should i just rebuild the collector end witch rotted off?

Thanks for the help!!!!!!!!!!!!!
 

·
Registered
Joined
·
46 Posts
I think most of them have a rough idle when cold, I know mine does.'

Have you checked for spark and fuel? I'd start there, too many variables to guess from.
 

·
Registered
Joined
·
2,428 Posts
Well, assuming there is no 'check engine' warning, start with the fuel filter if it hasn't be changed in awhile. Otherwise check the spark and fuel pressure as mentioned before. I am concerned about the y pipe corroding away, but Michigan winters are not kind to the undercarriage, and it is not the cause of you woes, but may be a symptom. A clogged catalytic converter can cause excessive back pressure.
 

·
Registered
Joined
·
109 Posts
Discussion Starter #4 (Edited)
I replaced the fuel filter yesterday and did the old blow through the old filter and there was a little bit of a restricktion. Checked air filter witch it fairly clean. Did not have any more problems with it dieing.. There is no Cat. Go Figure. lol. No check eninge light.

For the most part im pretty sure that the winters have takein care of the Y pipe. I have called Auto zone, Car Quest, Parts Plus, and check on the net and there is no after market Y pipe that i am aware of.

Opps failed to mention it has a 350
 
1 - 4 of 4 Posts
Top