GM Truck Club Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 99 Tahoe, has anyone had any problems with there ABS system? I have an intermittent problem, where under regular conditions and braking, the peddle vibrates and makes a "vrrrrrrr" noise. This happens every now and then and just when stopping normally, not slamming on the brakes or anything like that. The rotors and pads are all in great shape. Thanks ahead of time.
 

·
Registered
Joined
·
279 Posts
Is this a 2wd or 4wd? I think there was a GM bulliten where there was rust build-up on the reluctor wheel or the abs sensor in the hub had rust on it.
 

·
Registered
Joined
·
2 Posts
I have a 2000 Tahoe and had the exact problem. Tahoetroy was absolutely correct - it was a corroded brake sensor. It cost me $200 to have the dealership take care of the problem BUT it did fix it!!
 

·
Registered
Joined
·
61 Posts
Just in case anyone needs one I have a new wheel speed sensor that I no longer need I bought two to replace both of mine and ended up having to replace my LF wheel bearing which came with another sensor in it already so now I have a sensor that I do not need.
 

·
Registered
Joined
·
5 Posts
ABS problems

Is this a 2wd or 4wd? I think there was a GM bulliten where there was rust build-up on the reluctor wheel or the abs sensor in the hub had rust on it.
I am having a similar problem. I replaced both wheel bearing assemblies on my 99 2500 Suburban 4x4 about 6 months ago. When I first start up and go I will drive a little and then when I go to stop the brake pedal starts vibrating and the pedal goes to the floor and I can't stop. Usually the ABS light comes on and the brakes work again but without the ABS working obviously. The light goes out eventually and then it might happen again. Anybody have any ideas before I wreck?!?!
 

·
Registered
Joined
·
85 Posts
I am having a similar problem. I replaced both wheel bearing assemblies on my 99 2500 Suburban 4x4 about 6 months ago. When I first start up and go I will drive a little and then when I go to stop the brake pedal starts vibrating and the pedal goes to the floor and I can't stop. Usually the ABS light comes on and the brakes work again but without the ABS working obviously. The light goes out eventually and then it might happen again. Anybody have any ideas before I wreck?!?!

Are you loosing any brake fluid?
 

·
Registered
Joined
·
279 Posts
Try pulling the ABS fuse and driving the vehicle to see if the problem persists.
 

·
Registered
Joined
·
5 Posts
ABS Problems

I am not losing brake fluid. And my next thing to do was to pull the fuse and see what happens. If that is the problem where do go next? Thanks for everybodys help.
 

·
Registered
Joined
·
2 Posts
having same problem only on a 94 corsica

Hello I'm having the same problem with a car of mine.1994 corsica. My abs light has always been on since I had gotten it 2 years ago, but Somedays the abs is starting to not come on after I hit the 5 mile mark. So I know by then that I'm going to have problems. And I'll try not to drive it. When the abs light is off its feels as though the brakes are locking hard and releasing real fast and times the brake pedal will just go to the floor and I have no brakes. After a bit though of driving the Abs light returns and I have no problems with the brakes what so ever. Untill I have to start the car again that same day. I have notice that the days that this does this it seems right after a snow or rain storm I took it to the dealership and they couldnt even pull the codes from the computer. They said If it drives fine when the abs light is on I could just pull the fuse And It would mostlikly make stop it from malfuntioning. But then they said they couldnt pull mine because my altanator is on the same fuse. So now what?? Is there Another Way That I can do this. lol:grrrrrr:
 

·
Registered
Joined
·
5 Posts
abs problems

Well I pulled the fuse and sure enough the problem has gone away but so has the ABS. My friend has a code reader and I am going to see if the problem has left any trouble codes if not I don't know where to go. I need to figure this out because camping season is coming and I would rather not have any trouble with the brakes while I am towing, they are bad enough by themselves but that is for a different forumn.
 

·
Registered
Joined
·
61 Posts
If you pulled the fuse and no problems then I would assume that one of your speed sensors is bad. THey are about 125 at chevrolet I have one im selling for 50 shipped brand new still in the packaging if you are interested. To tell which one is wrond I belive you can take a resistance reading from the sensor.
 

·
Registered
Joined
·
2 Posts
Abs

My ABS and my altanator is on the same fuse. And I'm wondering what can I do about disabling the abs .
Im having the same problems with my abs as everyone else on this forum. but because of the altanator being on the same fuse, I cant just pull it out. No one will help me and I'v heard that you can put your abs on a switch I just need to know how. Shes a good working cart but I might have to just junk her
I cant even get anyone to even look at the car once I mention my abs problem
 
1 - 15 of 15 Posts
Top