GM Truck Club Forum banner
1 - 5 of 5 Posts

·
Registered
2004 Silverado 1500 4WD Crew cab 5.3L
Joined
·
27 Posts
Discussion Starter · #1 ·
Does anyone have information on how to do a relearn proceedure for an 04 silverado 4WD with 5.3? I went to start the truck and it just cranks, and the lock icon light illuminates. Any help would be great.
 

·
Registered
Joined
·
217 Posts
The following is the Auto Learn Procedure:

1) Insure the ignition key is in the ON position.

2) Clear all EVO/passlock™ module and VCM/PCM DTCs. Record and refer any VCM/PCM DTCs to:
- For 5.0/5.7L engines, refer to Powertrain On Board Diagnostic (OBD) System Check in Engine Controls - 5.0/5.7L

3) Momentarily rotate the ignition key to the CRANK position (Do NOT start the vehicle), then release it to the RUN position (Do NOT key OFF in the process).

4) Wait 10 minutes. Observe the SECURITY indicator. Refer to the following list for the appropriate responses:
  • If the passlock™ sensor was replaced the SECURITY indicator will flash for the 10 minutes duration.
  • If the EVO/passlock™ module was replaced, the SECURITY indicator will flash for a few seconds and then remain ON for the remainder of the 10 minutes duration.
  • If the VCM/PCM was replaced with a new programmed VCM/PCM and connected to the vehicle for the first time, the vehicle will start and this procedure may not be necessary.
  • If the replacement VCM/PCM was connected to any vehicle at any other time, even momentarily, the SECURITY indicator will flash for a few seconds and then remain ON for the 10 minutes duration.

5) The SECURITY indicator will transition from flashing to ON briefly to OFF after 10 minutes if remaining in the ignition ON position.

6) Turn the ignition switch to the OFF position and wait for 10 seconds.
Repeat steps 3-6 two more times. The new security code is ready to be communicated among the Passlock sensor, EVO/Passlock module and VCM/PCM.

7) The new password is learned on the next ignition lock cylinder cycle from OFF to CRANK to ON (start attempt).
 

·
Registered
2004 Silverado 1500 4WD Crew cab 5.3L
Joined
·
27 Posts
Discussion Starter · #4 ·
It's fixed. I had disconnected the battery a week ago to do some welding on my bumper. The truck worked fine for a few days, then all of a sudden got the security symbol flashing on the dash while trying to start. I discovered a thread on another site that said one option was to disconnect the battery for 30 minutes then reconnect the battery and use either the key fob or key to unlock the vehicle. I tried this option first and it worked. Thank you REDVET for your input. That option would have been my next try.
 
1 - 5 of 5 Posts
Top