GM Truck Club Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
im new to the forum, any help will be appreciated. I own a 1994 3/4 ton 4x4 suburban with 454 TBI. i installed new crate motor 2 years ago, its got about 50k miles on the motor and new tranny. my sub was running fine and all of a sudden shut off, towed it home ,I started it the next day then after about 10 minutes it started sputtering ,injectors were delivering more fuel than usual.it would not idle and then eventually die, I cannot raise rpms ,sometimes it backfires inthe throttle body.
i replaced plugs,wires,cap and rotor, and fuel filter. started ran better and after 30 min it started doing the same crap. I installed fuel pressure gauge before fuel filter to check psi .key on engine off 35psi ,and key on engine on 35psi, then when i shut off it instantly goes to 0psi does not hold pressure.I removed tbody and inspected pressure reg,eveything was fine exept that fuel return hose seemed resistant to flow ,I used airline to blow into return line ,still think this is my prob.installed everything back ,still runs rich!! Im will be cleaning my IACV ,checking tps,Map,Temp sensors,I know my fuel pressure should be 12 to 15psi, thats why I think it is a kinked hose or something in the return line, by the way gas tank is venting properly and canister purge is fine. am i way off ? can anyone shed some light?i will be checking egr valve but im trying to keep it simple for now.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #2
RE: are you a TBI guru? HELP!!

i have checked tps,iac solenid valve,and map sensors,they are all working properly,after checking the sensors i started the motor ,without problems ,it was running great and the spray pattern on the injectors improved dramatically. so i ruled out my pump,can a bad ,lazy linear egr valve be my intermittent problem?fogot to tell that my computer has not set a fault code.
 

·
Premium Member
Joined
·
1,625 Posts
RE: are you a TBI guru? HELP!!

You can check the injector pattern with a timing light. Just attach normally and shoot the injectors. you should see a nice cone pattern under the injectors.

The amount of pressure you have is way to much.

The instant drop in pressure is supposed to happen with this type of system. Built in to the system.

Sounds like an intermittent problem and those are the worst to track down, especially when they are not sending codes.

Good luck,
 

·
Registered
Joined
·
25 Posts
Discussion Starter #4
RE: are you a TBI guru? HELP!!

what is the required fuel pressure for my vehicle? 10 to 15 psi? it ran fine over the last two days ,and today in the morning it started doing the same thing .
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
RE: are you a TBI guru? HELP!!

today i to replaced fuel pump and replaced thermostat ,flushed the radiator and added new coolant.seems to be running fine, a little bit better . i checked fuel pressure and its still 32 psi. the chilton manual says 9-13psi . but the fuel pressure tester manual says it has to be 9-32psi ,1994 7.4L 4x4 3/4ton suburban . what the !! who is right???
 

·
Premium Member
Joined
·
1,101 Posts
I have seen both numbers used, so I am not sure which is correct. I do know that when I worked on an 89 dually with a 454 tbi a few years ago, I ran it with the air cleaner open and it looked like a couple of faucets had been turned on. That thing shot a bunch of fuel through it.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #7
GaryL said:
I have seen both numbers used, so I am not sure which is correct. I do know that when I worked on an 89 dually with a 454 tbi a few years ago, I ran it with the air cleaner open and it looked like a couple of faucets had been turned on. That thing shot a bunch of fuel through it.
thats exactly ,what it was doing. it runs good for now ,just have to wait and see if it acts up again.as for the fuel pump pressure ,i called a local gm dealership ,service writer told me pressure should not exceed more than 20psi. I need a gm factory service manual ,I think maybe the 454 tbi is an exception and runs on 9-32psi.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #8
bobby said:
GaryL said:
I have seen both numbers used, so I am not sure which is correct. I do know that when I worked on an 89 dually with a 454 tbi a few years ago, I ran it with the air cleaner open and it looked like a couple of faucets had been turned on. That thing shot a bunch of fuel through it.
thats exactly ,what it was doing. it runs good for now ,just have to wait and see if it acts up again.as for the fuel pump pressure ,i called a local gm dealership ,service writer told me pressure should not exceed more than 20psi. I need a gm factory service manual ,I think maybe the 454 tbi is an exception and runs on 9-32psi.
ok alldata says 26 to 32psi.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top