GM Truck Club Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I have a 1991 silverado ext cab. It has the 305 in it, I have had this idle problem for a couple of months and it is driving me crazy. It started one day like it runs perfect but if you come to a stop and hold the brake for a min. then the idle with slowly go down till it cuts off. It doesnt do it all the time but majority of it, I have checked for vacum leaks and couldnt find any, cleaned the tbi with cleaner. I finally put it in a shop and payed the guy to keep it for 2 days to tell me it needed a new computer, so I wasted the money and bought that and it didnt do anything. I have also replaced the fuel filter and no help. Sometimes it will even do it just idle in park and idle down till it cuts off, and only does it at normal temp. Just need a few more ideas of what it could be. Thanks
 

·
Registered
Joined
·
2,470 Posts
Tough one

Troubleshooting a rough idle is a complex process. There are many factors which affect the idle speed, some of which have already been mentioned. You need to get a checklist together and eliminate each item before moving onto the next. No one on the board will be able to point you to the single cause of your trouble. We can all share our experience but your results may vary. Your clues about the trouble being intermittent and that applying the brakes contributes may help, but in the end you have your work cut out for you if you are going to pinpoint the problem.

Here is a link to a troubleshooting guide for TBI that may help: affordable fuel injection
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
The shop I took it to checked the timing and said it was where it was supposed to be. No it has no check engine light and is throwing no codes. Was considering changing spark plugs and/or wires.
 

·
Premium Member
Joined
·
1,786 Posts
Did you change the plugs?

If not change them.

Also it can be something as simple as a loose plug wire, or defective one. Grab a hold of the plug wires and wiggle them. Now that I have your attention, because you just shocked yourself.

Does the engine skip or idle ruff? Those are signs of a missing plug or bad wire or loose wire.
 

·
Registered
Joined
·
4 Posts
I would replace your vacum lines, clean your injectors , check fuel pump and filter, spark plug wires, spark plugs, distributer, thats all i can think of right now, tps or throttle posisition sensor, the iacv or idle air control valve as well. hope you find the problem and hope this helps
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top