GM Truck Club Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
Ok so I am having a problem on my 99 suburban. If i hit unlock none of the doors will lock or unlock, they will "try" but its as though they arent recieving enough power. When I searched on the site for this type of problem i read somthing about the "body controler" Can this be adjusted or does it just need to be replaced?
Also, I do not have a Fob for it, didint have one when i bought it. I assume they all came with this originally. Do i just need to go to the dealership? Anyway, i really would like ta fix the door lock problem. thanks.
 

·
Administrator
Joined
·
4,886 Posts
If it's a 99, it didn't necessarily come with keyless entry becuase it was still an option for that year.

Everything else on the vehicle runs normally? Check the fuses, etc?
 

·
Administrator
Joined
·
4,886 Posts
... and if all of the doors are unlocked, do they lock when you push the lock button? (You only mentioned they won't unlock)
 

·
Premium Member
Joined
·
1,625 Posts
I wonder if the switch itself is bad?

Least expensive and easiest repair to do, unless anyone else has any ideas.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
neither lock or unlock will work. Cant be a fuse because they are getting juice...just not enough, i would think it is a mechanical problem (dirty or gummed up) but all locks do the same thing. Its not a switch, cause they all respond to any switch. Thanks for the input about it possibly not having keyless entry, i was not aware of that. thanks guys. Anyone have any experience with the body controller? i really think it could be that, but id like to hear from somebody who had to mess with it.
 

·
Premium Member
Joined
·
1,625 Posts
neither lock or unlock will work. Cant be a fuse because they are getting juice...just not enough, i would think it is a mechanical problem (dirty or gummed up) but all locks do the same thing. Its not a switch, cause they all respond to any switch. Thanks for the input about it possibly not having keyless entry, i was not aware of that. thanks guys. Anyone have any experience with the body controller? i really think it could be that, but id like to hear from somebody who had to mess with it.
Maybe a mechanical problem if it was just one switch that didn't work, or one selonoid, but not all.

Gummed up switches, 1 sure, 2, Maybe, maybe. They do get dirty in there so it is possible.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Yeah that was my thinkin, if it was just 1 or 2 doors acting up, or 1or 2 switches not working....then maybe mechanical. But all switches and solenoids are doing the same thing...cant quite move the lock up or down...and if you keep pressing the switch, they slow down as if they are losing more and more power. Im about to go find that thing under the dash and see if there is any type of calibration that may be off.
 

·
Premium Member
Joined
·
1,625 Posts
Yeah that was my thinkin, if it was just 1 or 2 doors acting up, or 1or 2 switches not working....then maybe mechanical. But all switches and solenoids are doing the same thing...cant quite move the lock up or down...and if you keep pressing the switch, they slow down as if they are losing more and more power. Im about to go find that thing under the dash and see if there is any type of calibration that may be off.
PS

I hate electrical problems, good luck.
 
1 - 9 of 9 Posts
Top