GM Truck Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey guys I have a 2000 c6500 dump that's been running like crap lately. It bogs down randomly when it's under loads/ going up hills. It helps intermittently to fill it up with desil. But the problem comes back. Also used desil clean injection cleaner stuff before with filling it up but again helps only intermittently. Iv replaced the desil filter under the hood recently as well not sure if theres another one. It has a cat 1236 engine in it. Any help much appreciated thanks -Eli
 

·
Registered
2000 Silverado Z71 4x4 5.3L 460k+ miles w/ GM rebuilt motor and trans
Joined
·
506 Posts
Well, the last one I worked on had 3 (yes, 3...) fuel filters. I found this out the hard way, since I ran it out of gas. 🤦‍♀️ You could try looking into the rest of your fuel filtration system to verify it is working. At the same time, check your fuel pressure to ensure you're getting enough juices flowing.

Is it throwing any codes?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Ya I was thinking there might be more. And it's a cat 3126* engine lol. Is there any chance you know the part numbers for them or have a pic with the diagrams? I got a plethora of fuel system diagrams that make my life harder, and they seem to call most things "filters" in diagrams these days..🤦‍♂️ Thanks - Eli
 

·
Registered
2000 Silverado Z71 4x4 5.3L 460k+ miles w/ GM rebuilt motor and trans
Joined
·
506 Posts
I don't, unfortunately. It was a company truck I borrowed for an errand that went awry.
 

·
Registered
Joined
·
1 Posts
Hey guys I have a 2000 c6500 dump that's been running like crap lately. It bogs down randomly when it's under loads/ going up hills. It helps intermittently to fill it up with desil. But the problem comes back. Also used desil clean injection cleaner stuff before with filling it up but again helps only intermittently. Iv replaced the desil filter under the hood recently as well not sure if theres another one. It has a cat 1236 engine in it. Any help much appreciated thanks -Eli
If it runs fine when full, then acts up as you lower the volume, could be the fuel pick up line in the tank. They are prone to crack
 
1 - 5 of 5 Posts
Top