GM Truck Club Forum banner
1 - 2 of 2 Posts

·
Premium Member
Joined
·
6,542 Posts
I think you have two sepparate issues working here.
#1 the picture leads me to believe the centering pin has sheared off or the rear axle "U" bolts are real loose.
Remedy: If the pin has sheared replace it with a similar sized bolt trimmed to fit. The centering pin isnt be a stress point so bolt strength isnt a big issue. Replace the "U" bolts, they shouldnt have come loose, this makes me think they might have been stretched and wont hold a good torque anymore.
This should fix your steering issue, the trucks trying to drive down the road sideways, probably looks pretty funny to the drivers behind you and with that snow on the ground I'm sure its a bear to handle right now.

#2 Probably a half shaft making all the noise up front. Look at the boot on the CV joint (the shaft running from the inside of the wheel to the front differential) see if its torn. More than likely it is and the CV grease has been flung out all over the underside of your truck, no one can tell you positively how long the CV's will last before they go out after loosing their grease, a safe bet would be very soon.
Remedy: Either you or a shop replaces the half shaft. If you got a week out of it already I'd say you already over extended your luck.
 

·
Premium Member
Joined
·
6,542 Posts
Good decision to replace those U joints, they're probably a few years old and I'm sure that axle going off center like that did some damage to them.
 
1 - 2 of 2 Posts
Top