GM Truck Club Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hope this is the right forum!

Check engine light came on last night ('96 Z71) while driving. Kept up at 55 just fine until I had to slow to under 20...tried to accelerate and truck sorta sputtered and was only able to go 20-25 mpr (very rough). Went up and over a hill and going down, coasted until 55mpr...truck ran fine again until I had to slow down. Made another attempt at accelerating and truck wouldn't pick up...starting hearing a banging under the hood on the passenger side. Pulled over & got a tow. :frown:

Tranny fluid was lower that expected, replaced fuel filter but still hesitating on the shift. Fluid doesn't smell like the "burnt almonds" as you might smell but engine is a bit louder.

Any suggestions?
 

·
Registered
Joined
·
2,428 Posts
Get the codes

If you don't have a code reader, borrow one from a local parts store (Autozone) More info will make for a better diagnosis.
 

·
Administrator
Joined
·
4,886 Posts
Any update on this? It sounds like it could be a number of differnt things. I'm curious what the codes were.
 

·
Premium Member
Joined
·
1,625 Posts
I really miss the old days when all you needed to get a code was a paper clip a pen and paper.

Now days with all computerized equipment in the running gear you got to be an engineer to fix something.

And we all know how much I dislike engineers.
 

·
Registered
Joined
·
15 Posts
Hope this is the right forum!

Check engine light came on last night ('96 Z71) while driving. Kept up at 55 just fine until I had to slow to under 20...tried to accelerate and truck sorta sputtered and was only able to go 20-25 mpr (very rough). Went up and over a hill and going down, coasted until 55mpr...truck ran fine again until I had to slow down. Made another attempt at accelerating and truck wouldn't pick up...starting hearing a banging under the hood on the passenger side. Pulled over & got a tow. :frown:

Tranny fluid was lower that expected, replaced fuel filter but still hesitating on the shift. Fluid doesn't smell like the "burnt almonds" as you might smell but engine is a bit louder.

Any suggestions?
did u ever figure out the problem
 
1 - 7 of 7 Posts
Top