GM Truck Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hey everyone, i have been struggling with my climate control panel ever since i got my truck, but the heater somewhat worked so over the winter i didnt bother with getting the ac to work...anyway the truck is a 95 gmc sierra 1500, and when i got it the panel didnt work at all, so i bought a new climate control unit and installed it and it only works sometimes and when it does the first 3 clicks of the heater work and the last one doesnt, and only the defrost setting works none of the other ones do. I hear that the resistor is a common problem and i will replace this but is there anything else that would be the problem? Also, the ac pump is currently out of the truck, would that affect anything? thanks
 

·
Registered
Joined
·
1,144 Posts
The resistor is usually the main culprit when it comes to any climate control issues. If replacing the resistor doesn't work, it could be something bigger like the blower motor itself or the actual climate control unit. I don't think having the ac pump out of the truck will affect anything.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
okay thanks...like i said the climate control unit didnt work at all and the one in there now is new so hopefully its not faulty...and secondly the blower does turn on just not every level so could it still be the motor even though it turns on?
 

·
Registered
Joined
·
1,144 Posts
If the blower turns on and works but not on every level then it sounds like the issue is more likely the resistor.
 
1 - 5 of 5 Posts
Top