GM Truck Club Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I've got a '96 Z71 pickup that has a somewhat misterious clunk when I let off the throttle and then get back into it. The most noticable time is when going over a large hump such as a bridge or railroad crossing. I let off to slow down and the accelerate off of it. This occurs at low speeds, it's not like I'm hard into the throttle. The clunk sounds mid-to-rear of the truck so I originally thought U joints, but nothing seems to have any play in it as far as the U-joints go. There is a little play on either end of the driveshaft but not in the actual U joint. Should it have a little play? suggestions?... Thanks
 

·
Registered
Joined
·
284 Posts
spare tire tight?
 

·
Super Moderator
Joined
·
1,567 Posts
Do you have a slip yoke in the driveshaft? Those can clunk.

Have you checked shocks, springs, sway bars, etc. as far as suspension goes?
 

·
Registered
Joined
·
57 Posts
Pack your slip yoke with grease and put some on the splines. What happens is they get dry sometimes and will clunk when the yoke moves in and out. Remember the end of the slip yoke has a little hole in it, so it can get a little dirty and rusty in there. Slip yokes on driveshafts with lube fittings will push grease out this hole. Worked like a champ on my daughters 92 Blazer. I thought her ball joints were bad, or a loose u bolt, or the rear slip yoke bushing might be worn. My transmission guy told me about this one. Saved me some money!
 
1 - 5 of 5 Posts
Top