GM Truck Club Forum banner

Crazy Problem Today

1989 Views 15 Replies 5 Participants Last post by  GM Customer Service
:grrrrrr:So today I went to Sam's club, and when I came out I started my truck up and everything was fine. The problem came when I put it in drive. When it in drive, my ABS light came on along with the service traction control light and Stablitrak notification. I knew something was up, but I had groceries going bad so I had to try and drive home. So I pull out and every time it shifted it threw you back into your seat extremely hard. So I was trying to drive slow and try to keep the truck from shifting as little as possible. Then, out of nowhere, the speedometer started just jolting all around jumping up and down, then the truck just died going down the road at 40 mph. So I coasted to a stop on the side of the road and turned the key off for about 10 minutes. I tried starting it up and everything was back to normal no lights at all. I got home and plugged it up to my programmer that was not in my truck and the truck had thrown no codes!! I had no reverse for a day back in January, that also threw no codes.



Dealer said maybe the throttle body. I am going to take it to them today in about an hour or so and see what they can do. Probably nothing since it didn't throw a code, which makes me pretty mad.

HELP!!!!
1 - 1 of 16 Posts
Not sure if this helps, But i had a very similar problem with wifes Stratus a few years back. Dealer put 2 computers in it, but it would still just die going down the road and gauges acted crazy like yours.. Turned out to be grounding problem. A mechanic friend of mine replaced the ground cable associated the the ECU and problem solved.

Not that grounding is your issue, but it may be a wiring problem, especially if its intermittent.
1 - 1 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top