GM Truck Club Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
'03 Tahoe
My driver seat just stopped, of corse not where I need it, the dealer says there's no manual override (that's smart). Any ideas on getting this to move so I can drive this thing a bit safer until it's fixed? Thanks
 

·
Registered
Joined
·
9 Posts
That just happened to my 03 Tahoe.

If yours is equipp'd as mine.....power memory seats, heated seats...etc , then you will have a control module under the driver's seat.

What happened to mine was the electrical connection at the underside of the seat was melted. There is a main power feed and ground feed....right next to each other, (another GM brilliant move) and the ground wire melts inside the plug and looses contact.

The result of non functioning power driver's seat and both front seatheaters. The passenger power seat works fine.

To fix the problem:

Reach under the seat at the plug and move the wires around while someone holds the power seat switch forward and the seat should move up and you can see the plug and wires.

Next unplug the seat wiring from the floor wiring and look at the plug..(mine was black inside)....
what I did was cut the red and black feed wires(the thick 10gauge wires)and made a new connector and joined them up by adding some wire to each and soldering them in place.

Now it works fine...however, if yours still doesn't work after doing this, its possible that the power seat control module has blown.
Hope this helps

Take care
Steve Vancouver B.C.
2003 Chevy Tahoe
2002 Oldsmobile Bravada

 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks Steve, it was 1 wire in the connector that came loose, don't know how. I ended up taking it to the dealer yesterday afternoon and after 150 in labor and 18 for 'shop parts' it was fixed. But I'm glad to see your post, if it ever happens again I'll remember what you said and give it a try.
 

·
Premium Member
Joined
·
4,886 Posts
Wow, sorry to hear about your problem from just one wire. Happy to know that they fixed it though.

For the want of a nail, the Tahoe was lost...
 

·
Registered
Joined
·
13 Posts
Thanks for your post. Luckily I only had a loose connection. Problem solved and no trip to the dealer.

Bentley
 

·
Registered
Joined
·
13 Posts
Sounds like the switch is nuked. If the lights come on when you press the button, there must be power at least to the switch. You could remove the door panel and test the output side.
I've had two issues with the seats in my Silverado. 1st was the connector under the seat. It can easily be bumped and then you lose all power to the seats. 2nd problem occured when a wire had broken off in the door bellows. This problem was off and on as the wire made contact intermittenly. Patched that up and end of problem.
Haven't had any issues with my Tahoe but it's a bit older (2000).
 

·
Registered
Joined
·
184 Posts
I also have problems with my seat heater on the drivers seat in my 03 Avalanche, it turns on and starts to get warm and shuts off. The passenger side is fine, I have had problems before and my breaker was bad, but everything quit when it went bad. I guess I will have to check my wiring under the seat. I already checked everything in the door and its all good.
As long as the passenger side works so I don't have to listen to the whining that the seat is cold, it's all good!
 

·
Registered
Joined
·
13 Posts
"As long as the passenger side works so I don't have to listen to the whining that the seat is cold, it's all good!"

That, is funny. And so true.

The driver's side on my Silverado gets way warmer than the passenger side. Don't know why. Also, for the last three years, when I would use the remote starter and the outside temp was below freezing, the seats would come on automagically. For some reason, this doesn't work anymore. It quit doing this after the truck sat for three days. No one else I know has working nor do I know if it was something programmed in by the remote starter installers.
 

·
Registered
Joined
·
1 Posts
Hey Steve ( Tazman), thanks for posting your repair---I was able to google the problem, find you post and fix my '04 Chevy 3500 in less than a hour. Nice to be able to move the seat again! My black wire was nuked in the connector, cut the ends off, spliced in a new piece and all working again. Appreciate it, buddy!
 

·
Registered
Joined
·
42 Posts
Thanks Tazman! I just "fixed" my '07 burb by pushing on the connector. If it comes back I'll look for a damaged wire.
 

·
Registered
Joined
·
1 Posts
I have a 2008 Suburban and my passenger seat reclined and will not go back up. All the other buttons on the side of the seat work fine. The only button not working is to make the seat come up and recline. I don't know if I just have a switch problem or motor problem. Although I think that if it were a motor problem none of the other switches would work either. Does anyone have any recommendations on where to go from here? Thank you!
 

·
Registered
Joined
·
5,200 Posts
[snip]
As long as the passenger side works so I don't have to listen to the whining that the seat is cold, it's all good!
How so very true. You too have a SWMBO. :)

TED
 
1 - 13 of 13 Posts
Top