GM Truck Club Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Any help would be greatly appreciated. I changed the battery on my 2014 silverado. Hooked it all back up and the only thing it does is dings as it usually does. Nothing else but the door locks work.
 

·
Registered
2000 Silverado Z71 4x4 5.3L 460k+ miles w/ GM rebuilt motor and trans
Joined
·
709 Posts
Did you lock yourself out with the security system?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
I'm not sure. The headlights, dome lights, door locks and, right turn signal are the only things that work. Would the security system cause this problem? Trying to figure this out before I get robbed at the dealership.
 

·
Registered
Joined
·
14,527 Posts
This makes no sense unless you popped some fuses.
Did you accidently connect the battery backwards?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Didn't put the battery in backwards. But my son finally told me today that he accidentally sparked the battery when he was tightening the battery cable. The strange thing is that when it first happened, only the door locks worked and nothing else. Today the headlights and tail light are working and the dome lights are working. I plugged in a code reader and it does nothing. Doesn't come on or anything.
 

·
Registered
Joined
·
14,527 Posts
Check all of the fuses.

A battery will spark when the 2nd cable is connected, the is not unusual.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
I wish that was it but he said that he initially forgot to reinstall that cover thats on the battery with the studs on it. When he was tightening up the negative cable.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
He accidentally touched one of those studs with the ratchet when he was tightening up the negative cable. He'd already put the positive cable on.
 

·
Registered
Joined
·
14,527 Posts
Then you may have wrecked the battery, do you have a voltmeter?
 

·
Registered
2000 Silverado Z71 4x4 5.3L 460k+ miles w/ GM rebuilt motor and trans
Joined
·
709 Posts
Depending on the duration of direct contact, there may be truck specific and battery issues... I would have the battery tested then crawl through all the fuses and relays.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
I checked the battery and it's fine. Does anyone know where the mega fuse is? I want to check that before I have it towed to the stealership. Lol
 

·
Registered
Joined
·
14,527 Posts
I wish that was it but he said that he initially forgot to reinstall that cover thats on the battery with the studs on it. When he was tightening up the negative cable.
What's this cover your talking about?
And, it has studs. Are these studs connected to the battery pos?
If they are not connected to pos, there would not be a spark if hit while tightening the neg cable.
 
1 - 13 of 13 Posts
Top