GM Truck Club Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
394 Posts
Discussion Starter #1
Hey ya'll I have a 2010 GMC Sierra 1500 SLE Extended cab, and I've just developed a problem with the rear right dome light. Well, it's not workin! I think there might be a problem with the physical connection to the bulb as when I apply pressure to the rear contact and push it towards the rear of the cab, the light works. However as soon as I let off the pressure, the light stops workin again :grrrrrr: ! Was wondering if it's just a soldering fix, or if somethin more serious is happinen. Don't think it's the issue, but I also replaced all the dome lights with L.E.D. replacements about 2 months ago. None of the other lights are acting up, but thought I'd throw that in there. I do have an appointment to take the truck to the dealer for routine oil change, and to look at the light unless I can figure out what's goin on before hand. Thanks for ya'll help!

~Josh
 

·
Registered
Joined
·
660 Posts
Josh,

I am glad to hear that you are planning to work with your local dealership regarding this concern. Please feel free to keep me posted. Thank you in advance.

Tricia, GM Customer Service.
 

·
Registered
Joined
·
1,218 Posts
Hey ya'll I have a 2010 GMC Sierra 1500 SLE Extended cab, and I've just developed a problem with the rear right dome light. Well, it's not workin! I think there might be a problem with the physical connection to the bulb as when I apply pressure to the rear contact and push it towards the rear of the cab, the light works. However as soon as I let off the pressure, the light stops workin again :grrrrrr: ! Was wondering if it's just a soldering fix, or if somethin more serious is happinen. Don't think it's the issue, but I also replaced all the dome lights with L.E.D. replacements about 2 months ago. None of the other lights are acting up, but thought I'd throw that in there. I do have an appointment to take the truck to the dealer for routine oil change, and to look at the light unless I can figure out what's goin on before hand. Thanks for ya'll help!

~Josh
If its under warranty let the dealer fix it...............
 

·
Registered
Joined
·
394 Posts
Discussion Starter #4
Hey ya'll! Well as an update, it turned out that problem was just a loose connector. So thankfully it was an easy fix (if I didn't have an appointment already, I probably would have been able to look at it closer!). Ya'll have a good day!:great:
 
1 - 4 of 4 Posts
Top