GM Truck Club Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1
Very odd...on my way home tonight...stopped at a light...turned green..went to go, lightly as usual...but the engine just revved slowly like in neutral...felt a little catch and heard what sounded like the transfer case making some engaging sound...and then let off and hit it again, lightly..still no grab....and did it again, and it finally got the truck moving...but didn't feel fully engaged or anything
going down the road at about 40 about 500 feet down the road, i let off completely and then went WOT for a second to test down shift engagement and only down shifted once and felt REALLY lethargic.


Continued driving normally, and in the next 3 stops on the way back...no other hesitations...

wtf is the deal there? Checked fluids....transmission is full and clean clear pink.

This thing has SO many separate control systems I wouldn't even know where to start to look, other than the basic fluid condition and other obvious things...

just find that odd....

doubt i should be worried...but its just one of those things that kinda bothers you on a 37k truck
 

·
Registered
Joined
·
84 Posts
Discussion Starter #3
Seems to be acting normal for the most part. Did another 4 of those hesitations after my first post...latest being yesterday. Now it just feels like it wants to catch..stumbles...you let off.and go and its fine again. Otherwise, it seems to shift fine. Transfer case is working fine as well, Auto 4, 2, 4HI and 4LO are working alright and engage on demand. Overall performance is normal as well, gets seriously moving when you want it to.

I am taking a trip in one month, early may...gonna be a 2800 mile trip. Really need this to be nice and happy before I leave. Service plan in ranking order is as follows.

1. Transmission flush (Dealer, Dex 6)
2. Oil change (Mobil 1, PureONE)
3. Air Filter (PureONE)
4. Rear Differential (Amsoil Severe Gear)
5. Front Differential (Amsoil Severe Gear)
6. Coolant Swap (Green to replace DEX)

I hope to get some of that done before I leave, but I'm thinking only the first 3, maybe 4, are actually going to happen.

I know what I'm doing in this situation, but I am always open to all suggestions.
 

·
Registered
Joined
·
27 Posts
Do you have a "Fly by wire" throttle??? If so check the pedal (not real familiar with them BUT) circuit for flat spots and opens (linear rheostat?!?!) like you would on an older TPS. Also check the throttle valve unit for binding, opens, flat spots.

One other thing is have the dealer check the PCM, and BCM for control faults for the throttle and transmissions. Remember some codes do not trip the CEL light.

Larry
 

·
Registered
Joined
·
84 Posts
Discussion Starter #5
yeah, I have drive by wire. I believe thats a 2004+ thing.

I was thinking that too, apart of my constant disliking and doubting of the drive by wire system...but have eliminated it because the engine revs, but the truck doesn't move when this happens. and you can always hear the transmission or transfer case doing SOMETHING. dunno what.
 

·
Registered
Joined
·
279 Posts
Nexttime it happens try and pull transmission into manual 1 and see if it makes a difference, putting it into manual 1 gets rid of the low roller clutch and engauges the low/reverse clutch.
 

·
Registered
Joined
·
27 Posts
the other thing with the tranny is, when it goes into limp home mode, 1st is locked out (or slips like all get out.) it will go into 2nd and work in 2nd normally. Try manual 2. If it slips in man 1 but moves in 2nd then I'd say you have a problem in the electronics inside the trans. 1-2,2-3 solenoids come to mind. They are a not so uncommon problem with the 4L60E and in some cases the 4L80E. They are relatively cheap ($18-25ea vs 2400 for tranny) and easy to install.

If you do open it up, it would be a good time for a drain, change filter, and fill. I drain mine thru the coolant line and add 4-8 quarts and flush it out. When it's empty the remaining fluid should be predominately new. Change the filter, install new solenoids, and put new 2nd and 4th servo's (corvette 2nd and billet 4th). They'll improve holding power in 2nd and 4th, improve shift quality in all gears.

I've got a copy of the factory 4L60E manual in pdf form. If you want a copy e-mail me at lderouin at comcast DOT com. (substitute @ for @ and . for DOT)


Larry
 

·
Premium Member
Joined
·
1,101 Posts
I've got a copy of the factory 4L60E manual in pdf form. If you want a copy e-mail me at lderouin at comcast DOT com. (substitute @ for @ and . for DOT)


Larry
PM sent, email didn't work.
 

·
Registered
Joined
·
279 Posts
That is only the 4l60e "information" manual by Hydramatic, the repair manual is about 200 pages long. I will try and see if I have it. Also if any one wants to see the 4l80e "information" manual I will try and post it.
 
1 - 10 of 10 Posts
Top