GM Truck Club Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have an 88 gmc sierra. I've replaced the fuel pump 3 times and each time the truck will run for a few minutes and then die. When. It dies I lose fuel and fire. So I figured it was electric issue. I'm kinda new to the mechanical world but have a little common sense. So I replaced the coil thinking maybe it could be that as I don't have the proper tools to diagnose. Tha didn't solve it, checked fuses and all looked good. Wires and plugs are new. I changed the ignition control module yesterday and still nothing just cant seem to get fire any ideas?
 

·
Registered
Joined
·
16,239 Posts
Ok, you start off suspecting a fuel problem and end up trying to repair a spark problem.
Your first task is to figure out which is at fault
Start easy, spray a little bit of fuel into the throttle body, see if it starts.
If it starts, it will only run for a very short time, that's normal; but if will tell you that the fuel delivery is the problem
If it doesn't start, it likely a spark problem.

Report back here after you try the fuel test
 

·
Registered
Joined
·
6,299 Posts
replace the ICM and ignition coil ....I replaced it 1983 GM vehicle at around 225K miles ... I put it in my glove box ... then the engine started and died .. then I installed it in the parking lot ... engine had hesitations prior to the engine run drop ..
my 1996 GM Impala had ignition coil arcing had miss fires .. I replaced the ICM and coil ...
 

·
Registered
Joined
·
10 Posts
I have an 88 gmc sierra. I've replaced the fuel pump 3 times and each time the truck will run for a few minutes and then die. When. It dies I lose fuel and fire. So I figured it was electric issue. I'm kinda new to the mechanical world but have a little common sense. So I replaced the coil thinking maybe it could be that as I don't have the proper tools to diagnose. Tha didn't solve it, checked fuses and all looked good. Wires and plugs are new. I changed the ignition control module yesterday and still nothing just cant seem to get fire any ideas?
You said you replaced wires. Did that include the coil wire?
 
1 - 4 of 4 Posts
Top