GM Truck Club Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
603 Posts
Discussion Starter #1
So I've had my new 2011 2500 HD for about 3 weeks and have usually kept it topped up with fuel. when it gets to half I fill it up. No issues until today I was at 1/4 tanks put in 80 liters and when i started the truck the gauge barely moved. turned key off, restarted and it went to 1/2 then slowly climbed to 7/8. I did not let the nozzle click off just put in $100. and stopped. Any ideas?
 

·
Registered
Joined
·
1,144 Posts
Could just be a freak glitch. I know the 03-06 trucks have a lot of issues with the gauge clusters, but I've never heard of that happening on a 2011 model. It's probably nothing and I would just leave it be. If it happens again and more frequently, I would disconnect the negative battery cable, wait a few minutes, then re-connect it. I use this method all the time and it usually fixes any strange electrical issues that may be going on with the gauge cluster and the vehicle's electronics in general.
 

·
Registered
Joined
·
660 Posts
I would have to agree with the previous post. It may be that the gauge needed some time to reset. If this does happen again, I would recommend contacting your local dealership. You can also contact me by private message. Thank you.

Tricia, GM Customer Service.
 

·
Registered
Joined
·
603 Posts
Discussion Starter #4
Seems to be back to normal. See what happens when I put Gas in next. thanks for the replies.
 
1 - 4 of 4 Posts
Top