GM Truck Club Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
latley getting gas in burb it pings like crazy it never did it as much when i got her anybody else notice poor quality of gas too
 

·
Registered
Joined
·
2,966 Posts
Chinese gas?...Sum Ping Wong...


Sorry...my silly.


Any particular station? Not sure what your gas companies are called down there, but it might be just one company...
 

·
Administrator
Joined
·
4,886 Posts
Chinese gas?...Sum Ping Wong...


Sorry...my silly.


Any particular station? Not sure what your gas companies are called down there, but it might be just one company...
I thought Conoco was Japanese gas. "Co..noco."
 

·
Registered
Joined
·
12 Posts
latley getting gas in burb it pings like crazy it never did it as much when i got her anybody else notice poor quality of gas too
Remember, we're starting to see the "summer" gas in the green states. We get alot of this here in CA. What year is the burb and do you have any mods to it? The programmers (hypertech) advance the timing a bit which can cause this to happen if you don't change out the t-stat along with the retune. The t-stat temp goes colder to richen up the mixture. If you reprogrammed without changing the t-stat this could be your problem. You also might want to try resetting the trims and timing map on your ECU by removing the battery power for about 10 seconds. This would let the ecu relearn trims for the crappy gas.

Hope that helps!
 

·
Registered
Joined
·
20 Posts
ibought some gas below houston,at a shellstation and with in 10 milesi had problems with gas guage,,stopped and put in some injector clearner,and it cleaned the card in the tank and all has gone well,,abuelito
 
1 - 6 of 6 Posts
Top