GM Truck Club Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
So I recently purchased a 1986 K5 Blazer and the gauges don't work, neither do the interior lights. Fuses are in top condition.
The only thing I can gather that is the issue is that when the previous owner installed the aftermarket stereo system, they wired the orange illumination wire into the stereo to power it. Now, after I've purchased a new wiring harness I am planning on doing it correctly.

I've looked into the dash and checked the wires and found a black piece with a single grey/black wire into a black plastic piece, the orange wire should plug into it, but I can't figure out where the whole thing goes to once it's put back together.

In the picture, you can see the piece with the black wire and the orange wire is behind it, not plugged in (anymore).

Any help is greatly appreciated!
 

Attachments

·
Registered
Many... All Gm
Joined
·
704 Posts
So I recently purchased a 1986 K5 Blazer and the gauges don't work, neither do the interior lights. Fuses are in top condition.
The only thing I can gather that is the issue is that when the previous owner installed the aftermarket stereo system, they wired the orange illumination wire into the stereo to power it. Now, after I've purchased a new wiring harness I am planning on doing it correctly.

I've looked into the dash and checked the wires and found a black piece with a single grey/black wire into a black plastic piece, the orange wire should plug into it, but I can't figure out where the whole thing goes to once it's put back together.

In the picture, you can see the piece with the black wire and the orange wire is behind it, not plugged in (anymore).

Any help is greatly appreciated!
That's not the extension for your ash tray light is it?
 

·
Registered
Many... All Gm
Joined
·
704 Posts
If it is one of the light extensions, is it powered, does voltage drop when rolling dimmer switch? I have a similar parts truck out back, if you haven't figured it by tomorrow night I'll have a look.
 

·
Registered
Many... All Gm
Joined
·
704 Posts
I found the connection... In an 85 celebrity lol unfortunately mine was cut. The good news...the cluster and lighting works on this one. It has no stereo in it, but the orange wire was hanging with the rest of the stereo wiring. The connector below, with part of the orange still in it. I have to assume this is a lead for the stereo. I am having trouble finding anything but speaker wiring scims for this year set. Sounds like you're gauge cluster may be another issue. To be sure put a multi meter or test lamp to it, and pull fuse...see if it cuts power...if not replace and pull until you find the circuit... Then chase from there...if you want. If no test light, just wire up any 12v lamp. An 1156 from the tail light or something.
 
  • Like
Reactions: Invad3r
1 - 4 of 4 Posts
Top