GM Truck Club Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
My 2003 Z71 Suburban's driver heated seat is not operating as it should. When the key is first turned on the heater for the back is on full. Sometimes it can be adjusted down or switch to back and bottom heat, and sometimes it cannot be adjusted. Some other times (usually when I want it the most) it will cycle from high to medium to low to off, changing every several seconds. The time seems to vary, sometimes is will change every few seconds and other times it will change every few minutes. Does anyone have an idea what might be causing this?

Never thought that I would like heated seats and even find it funny that I would be concerned about such a feature, but after having them they are great. Especially for those big Ohio temperature fluctuations.

Thanks for any responses.
 

·
Premium Member
Joined
·
4,886 Posts
My 2003 Z71 Suburban's driver heated seat is not operating as it should. When the key is first turned on the heater for the back is on full. Sometimes it can be adjusted down or switch to back and bottom heat, and sometimes it cannot be adjusted. Some other times (usually when I want it the most) it will cycle from high to medium to low to off, changing every several seconds. The time seems to vary, sometimes is will change every few seconds and other times it will change every few minutes. Does anyone have an idea what might be causing this?

Never thought that I would like heated seats and even find it funny that I would be concerned about such a feature, but after having them they are great. Especially for those big Ohio temperature fluctuations.

Thanks for any responses.
Hmm, not sure if it's a module or simply a short of some sort? Anyone have experience with these?
 
1 - 2 of 2 Posts
Top