GM Truck Club Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
It's an 03 silverado. Last year the heater didn't work on the 1 setting,I didn't think muck about it.
About 1 month ago 1-2&3 went out and only 4 /5 work. I pulled the moduela form the back of the switch and called my local chevy stealer. They said 3-400 bucks!!!! I told them I had the part out and they then told me I'd have to replace the whole cluster.
That is the same $h1t I got last year when my speedo went out. I then ordered the sensor online and replaced it myself. I argued with them it was a problem . Thier response was they hadn't seen thsi, I offered to bring it in but never was contacted. The said 4-500 to replace the speedo cluster, I ordered 2 sensore and did it for 30 bucks...whats aholes. The I get a letter form GM that there MAY be a speedo prob...DUHHHHHHHH.
Anyway the part comes off the back of the fan switch and has a number of00337721. The plug has 5 prongs that plug into the back
Anyhelp is greatly appreciated

thanks

Mace
 

·
Registered
Joined
·
25 Posts
Mace, Is it your blower speed switch thats not working??
If it is, Its more than likley your blower control resistor located next to your blower motor.

As far as your cluster goes..I would take the parts reciept to your dealer and request "Goodwill warranty Help"
They are bending over backwards to help. Check your attitude at the door:)
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
It is the blower fan switch, it only works on the 4 and 5 setting.
Yea I know my additude is sour but I really was a nice guy the 1st time about the speedo and then didn't even get a call back and no interest in any help.
I even told them I'd pay for half since the truck had 60k and was4 yrs old.
They treated me like an ulgy redheaded step child

Mace
 

·
Registered
Joined
·
52 Posts
have you gotten anywhere with this .my 03 tahoe has the same deal.only 4 and 5 are working now??????
 
1 - 8 of 8 Posts
Top