GM Truck Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I am working on my uncles 99 chevy 5.3 and he was told the ecm was bad so I changed that out and still nothing from the fuel pump. I had a known good fuel pump that I dropped in and still nothing? What else do I need to look at? I am a cummins diesel guy so not sure where else I need to start looking on this truck. Thanks for the help.
 

·
Registered
Joined
·
8,623 Posts
Welcome to the club Stang. About all that's left that you haven't done so far is the FP relay & the wiring loom. Look for the FP relay on the firewall a little left of center
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Welcome to the club Stang. About all that's left that you haven't done so far is the FP relay & the wiring loom. Look for the FP relay on the firewall a little left of center

I swapped out the relay as well. Could it be the PCM/fuse panel itself? Which wire is the power wire at the tank that I need to check for?
 

·
Registered
Joined
·
8,623 Posts
Have you checked the relay to see if it's getting power to & out? I don't know the color for your truck cuz my diagram is not for that year, but it shows tan & white wire for the FP prime.
Have a helper turn the key while you check for power into & out of the relay.
 

·
Registered
Joined
·
1,700 Posts
Have you done a fuel pressure test? The two heavier wires at the pump should have 12V for about two seconds when you key on.
 
1 - 5 of 5 Posts
Top