GM Truck Club Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I hope some of you can help.

I have a 08 Silverado Z71 LTZ that has a roaring or humming sound while accelerating. The faster I go the louder it gets. But the noise goes away when I let off the accelerator and comes back when I get back on the gas. Doesn't do it in park or neutral, only when driving. Sounds like its coming from the rear of the Truck.. Truck is 100% stock.

Thanks
 

·
Registered
Joined
·
16,682 Posts
Usually that sound would come from under the hood.
If it is the rear, maybe an exhaust leak.
If it turns out to be at the front, look for a bad fan clutch (unless you have an electric fan);
Or a bad bearing in the tensioner, or idler pulleys.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
It only makes the sound when accelerating and gets louder with more speed. Let off the gas it goes away. Comes back just tapping the gas.
 

·
Registered
Joined
·
16,682 Posts
When you give it gas, the engine torque goes through the driveshaft and into the diff.

So, it is a u-joint, or one of the bearings in the diff
 

·
Registered
Joined
·
16,682 Posts
April, I suspect my last post was his, and your, problem. It took a bit to narrow it down; but I think his problem was a bad u-joint.
Roll the drivers window down when stopped, if you can hear it grumbling as you pull away and the noise stops as soon as you lift your gas foot, it's a bad u-joint.
 
1 - 10 of 10 Posts
Top