GM Truck Club Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi everyone, I'm new here, I would have said my intros in another forum, but I need advice quick. I have a 93 Chevy Suburban that has started to smoke when I turn on my headlights. There is smoke that streams out of the switch, and after about 5 minutes, the lights begin to flicker and I have to shut them off. I also noticed when I have to put my hazards on, there is a small stream of smoke that rises out of that as well. I have gotten suggestions such as a get a new switch, check the fuses, etc, but my husband also took off the panel and inspected it, but found nothing but a white greasy (lube??) under there, but no burns or anything indicating a problem, obviously there is one..
any help?? I can't drive at night now unless it's real quick with my parking lights on..:confused:
 

·
Registered
Joined
·
2,428 Posts
If it feels hot, it probably is.

Start by pulling the piece that surrounds the instrument cluster. Remove that and plug the headlight switch back in. If you don't see the source of the 'smoke' try touching different components and wires to see what feels hot. Keep the fire extinguisher handy.
 

·
Premium Member
Joined
·
1,625 Posts
Sounds like there is definitely something wrong.

Did hubby try to duplicate the problem when he had the dash apart?

That would be my first suggestion. At least then he could have a better idea of where the smoke is coming from.

Just at a guess I would say there is something wrong on the light circuit.

Did you just install something new? Radio, DVD player, fog lights, or some other thing that may be drawing extra juice?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
first off thanks for the replies. No, we have done nothing new to the vehicle since last year (we installed a cd player last year, and replaced the headlight bulbs late this winter) I read up today on so many fire hazards and actual fires with these trucks it's got me a little spooked now. I am going to search the forums suggested and see what happens, thanks again everyone, I'll keep you updated.
 

·
Registered
Joined
·
561 Posts
i had this same thing happen to me and it scared the heck out of me when the smoke poured out of the switch and it was real hot to the touch. i had to replace the switch. in fact i did a write-up on this.


here is the NAPA part number if you choose to use NAPA auto parts

this is a 15 min swap...mike
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
I wanted to update everyone who helped out with suggestions, turns out it was just the switch (thanks to collinsperformance for the photos) we replaced it and it's completely fine now, no smoke, no shorts, nothing.

I really appreciate everyones help and advice! Thanks again! :)
 

·
Premium Member
Joined
·
1,625 Posts
We are here to try and help.

Next question?
 

·
Registered
Joined
·
561 Posts
No problem. this is one of the reasons this club is here and avalable for all to help or get help. i am almost done moving so i will be in and out of the board alot ore soon again...mike
 
1 - 10 of 10 Posts
Top