GM Truck Club Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Have a 1990 GMC 2500. Started running rough and stalling out, eventually wouldn't start. Had plugs wires coil and a module by distributer replaced and now it's running. Won't move and was told transmission is gone. However when it started acting up it wouldn't up shift out of first gear. Any chance a sensor tripped when it wasn't firing right to shut down the transmission and it's still stuck in that mode. Just seems too random that all of a sudden when I started having firing issues that the transmission just happens to up and go at the same time.
 

·
Registered
‘01 Silverado 2500HD 8.1/Allison 5sp xcab long bed
Joined
·
3,497 Posts
Your ‘90 doesn’t have an electronic transmission unless someone put a newer one in. Did you move the the transmission cable on the top of the engine at all?

 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I had a friend's son who owns a shop do the work. I hardly ever work on stuff because I don't have anywhere to do it, have only a few tools, and unless I'm broke down on the side of the road with only enough $ to take a chance to buy a part and figure out how to change it, I get someone who works on vehicles to do it. I know tree work, I just haven't learned much about mechanical stuff. So I thank you for any info. I just can't afford to get taken again by a mechanic if there's a chance my transmission isn't done. He said he didn't do anything around the transmission. I'll ask him if he moved that cable, I take it that could effect it.
 
1 - 3 of 3 Posts
Top