GM Truck Club Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I was driving my new 07 Burb the other day and crossed a manhole cover in the street. The service traction control light came on---went to the dealer and they couldn't find anything--managed to reset the tire pressure sensor and somehow that took care of the traction system light.

Now the cruise control works just some of the time. The power indicator shows on the switch by the steering wheel, but the cruise won't engage and no light on the dash.

What gives???
 

·
Banned
Joined
·
372 Posts
I'm not 100% sure on this, but check your brake lights. Are they coming on? The cruise control (at least for my 05) is on the same circuit as the brakes (hence the reason cruise cuts off when brake is applied). If there is a short, or if there is some other kind of problem on that circuit, it could be the cause of your problem. The same thing happened to me and I had to have the electrical system analyzed and repaired. It wasn't a big deal, set me back around $150.
 

·
Registered
Joined
·
2,428 Posts
What's the significance of the manhole crossing? Did the wheels slip? Was the burb jarred?
 

·
Registered
Joined
·
533 Posts
I was driving my new 07 Burb the other day and crossed a manhole cover in the street. The service traction control light came on---went to the dealer and they couldn't find anything--managed to reset the tire pressure sensor and somehow that took care of the traction system light.

Now the cruise control works just some of the time. The power indicator shows on the switch by the steering wheel, but the cruise won't engage and no light on the dash.

What gives???
Being your truck is too new to even touch it ..you gotta bring it back to the stealership ... complain about the item and take note on anything else cause once that 36000 or so warranty is gone ...your gonna miss it

hope you took the GMPP
 
1 - 4 of 4 Posts
Top