GM Truck Club Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I drive an 88 suburban. it has a 350 in it. If you look in my sig you will see what the burb has in the engine. The problem is at idle, it will foul the plugs. It is TBI with A dontov 30 30 grind cam and L98 heads. Its scary powerful when it runs but the ECM (I don't think) can handle it. What do i need to do to get this thing to idle without fouling the plugs? Thanks in advance!
Will
 

·
Registered
Joined
·
51 Posts
What lift and duration are the cam specs? Chances are if it came out of a drag truck, both those specs are crazy huge. Way too much lift and way too much duration causing the combustion chamber to be washed out with too much fuel and the plugs can't burn it all off. If you are running a crazy huge cam, you need compression to make a complete burn. If you don't you're just throwing raw fuel out the tail pipe. First things first.. need the complete specs on the cam. At the very least I would say to install a complete MSD setup to get a better spark and run NGK's at the hottest range possible without detonation.
 

·
Premium Member
Joined
·
6,542 Posts
X2 on the cam lift and duration. That cam was ground for an engine that runs its life at a 1/4 or 1/8 mile at a time, plugs are changed or cleaned between runs and the ignition is much hotter than what your running now.
The choices are either change to a streetable cam grind.
Or An MSD ignition or comparable system with hotter plugs and live with some fouling.

You dont list the Header tube size or exhaust specs so I'm guessing 3", with that cam grind you probably want 3.5 to 4" with dual exhaust and short pipes. The engine will always have a high idle to keep from stalling and fouling worse than it already does.
 

·
Registered
Joined
·
4,151 Posts
I have a friend that put a 383 stroker motor in his 88 pick-up and it does not run right because the ECM needs to be re-programmed. He is going to get 500 miles on it for break-in and then an ex GM ECM guru is going to re-program it.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
I appreciateyour help and i did an MSD set up. its sad to say but, i really don't know what the specs are because it was the first engine i put tgether. I just did what my friend said to do. I bet i cn get that here in a day or too when i get back out there. Here is what i do know. We are running accel header plugs, the headers are3 inches at the collecters then 3 to the X pipe which filters down to 2 1/2 at the catalytic converter. 2 1/2 the rest of the way out. everthing else is stock. We are going to try MSD then MSD and and reflash, if that doesn't work new Cam. I appreciate your help. PLease if you have any more suggestions, pleas let me know, i will try and get the specs on the rest of this stuff today if possible. Once again i appreciate it!
Will
 
1 - 6 of 6 Posts
Top