GM Truck Club Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I've been looking for a hauler for trips to the hardware store and something with tow capability.

Anyhow, 2005 Trailblazer LS, 4wd. 102,xxx miles, with the I6. My ex-wife and I had a 2003 that although had a bunch of little issues over the years, the motor and trans held up well over 200k and it's still going now so I figured I'd give it a shot. It has new tires(less than 4k), new rear brakes, new a/c compressor and idler the day before I bought. Outside is decent for it's age, inside is virtually immaculate. Got her for 3200 so I'm thinking it was a fair deal considering how ridiculous current vehicle pricing is.

Few things I found wrong with it.

No fan on 5, i know it's the resistor pack by the glovebox, fixed that once on my ex's TB, no big deal.

When coming to a stop, under 5mph ABS kicks in sometimes. Research shows it's likely a rust issue(salted roads in wisconsin will do that), possible sensors, in any case not a major concern at this moment.

As I'm running down the road every once in a while the door chime goes off, only once. No dash lights no nothing, just a random one time chime. Can't seem to find any info on this problem.

The weird fluctuating lights. Noticed on the dome lights when I bought the vehicle, figured worst case scenario a new alternator is $200 or so and i can install myself so not too worried but that doesn't seem to 'fix this issue' from what i've seen. My voltmeter jumps from 14-15 as it's rolling down the highway. Lots of topics on this but don't seem to find a definitive answer on the real repair for this.

Ok people let her rip with comments and suggestions.

Thanks
 

·
Registered
Joined
·
13,634 Posts
The single chime could be the rear hatch is loose.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
well i found out the ding is when i hit 75mph. Must've been a cluster replacement at some point
 

·
Registered
Joined
·
13,634 Posts
Hmmm, I had an '05 and don't recall having that feature.
A friend has a Toyota with the ability to set a tone at a selected speed to reduce chances of speeding.
 

·
Registered
Joined
·
347 Posts
Hmmm, I had an '05 and don't recall having that feature.
A friend has a Toyota with the ability to set a tone at a selected speed to reduce chances of speeding.
That sounds like an early 60's Buick! If I remember correctly they also had a bar indicator for the speedometer, but since I've already given away my age maybe it's CRS!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Its not a standard feature. I just remember reading that if the cluster was replaced and they got one intended for overseas it had this 'feature'.

I guess it can be turned off via programming but it wasn't. Only thing that scares me now is if the mileage was altered but a vin check doesn't show any real discrepancies to worry about.

My 12 Camaro has the speed warning, i turned it off, it chimed way too often unless i set it way too high lol
 

·
Registered
Joined
·
4 Posts
My 03 TB had weird light dimming problems after I replaced the motor (absolute nightmare for me) then completely died everything. Just for fun I ran a wire from the body to the frame if I remember right might have been motor, it was along time ago, seemed to fix all my electrical issues
 
1 - 7 of 7 Posts
Top