GM Truck Club Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,106 Posts
Discussion Starter #1
What you think of my Kenwood install on my '87 Sierra Classic. Its my first install and i did it on my own.

 

·
Registered
Joined
·
1,106 Posts
Discussion Starter #3
thanks, since it was my first i learned a few things. it isnt as hard as i thought to wire it up but getting the old one out was a PITA
 

·
Registered
Joined
·
2,966 Posts
Nice job, Matt! Ya did great :great:
 

·
Super Moderator
Joined
·
3,391 Posts
thanks, since it was my first i learned a few things. it isnt as hard as i thought to wire it up but getting the old one out was a PITA
As long as you have a wiring harness for the truck that plugs into the factory connector, it's a simple job of matching wire colors. Now, getting the dash bezel off...that's a major b*tch. Every time I go to pull it off, I cringe and start thinking about whether I REALLY need to get whatever I needed to do done. However, once I figure out how to get the headlight switch off, it became easy, but tedious with all the screws. Good job on the install. That looks cleaner than my install, which install kit did you use?
 

·
Registered
Joined
·
1,106 Posts
Discussion Starter #6
As long as you have a wiring harness for the truck that plugs into the factory connector, it's a simple job of matching wire colors. Now, getting the dash bezel off...that's a major b*tch. Every time I go to pull it off, I cringe and start thinking about whether I REALLY need to get whatever I needed to do done. However, once I figure out how to get the headlight switch off, it became easy, but tedious with all the screws. Good job on the install. That looks cleaner than my install, which install kit did you use?
i got everything for the install from crutchfield.com thats the best place to get anything audio/video for a vehicle from. cutting out part of the dash to fit it was the hardest part. thanks for the compliment. lets see a pic of your install cause i bet it aint that bad
 

·
Super Moderator
Joined
·
3,391 Posts
OK, I finally got around to taking a few pics of the install in my Suburban. Mind you, this is an old POS radio that was in my first car, but it's better(barely) than the factory head... I know Md4x4's been asking me for these, so here they are.





 

·
Registered
Joined
·
2,428 Posts
Hmmm...choices

Which Kenwood did you go with? I was looking at both the Kenwood KDC-X491 and the Blaupunkt Melbourne SD27. I like the Kenwood for the front USB port, but the Blaupunkt drops the CD in favor of an SD card slot. I can't seem to get a CD player to last much more than a year. The CD player in the Alpine I have died so I'm looking.

 
1 - 10 of 10 Posts
Top