GM Truck Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
170 Posts
Discussion Starter #1
Guys, took the suburban on its first drive of any significance (50 miles round trip) this weekend, and noticed a couple of things that I hope you can help out with...

1.) Under the driver side dash, it blows a blast of heated air when you accellerate from a stop, up until about 20 MPH. Thats the only time I notice it. I thought it might be a busted mixing valve, but that doesn't explain the speed sensitivity.

2. Between 55-70 MPH there is alot of bass rumble coming from the passenger front tire area. I checked the tire and the pressure is fine and there weren't any blisters or anything. All the u-joints were replaced about three months ago, the fluids were all changed earlier this month. I don't know what might be causing it, but the two possibilities that I though of are either a blown shock (doesn't effect the ride any, so probably not) or someone used some fix-a-flat on the tire at some point and it is causing the tire to be imbalanced.:no:

Also, someone apparently stole the reciever hitch off the back of the thing, can you believe that?:grrrrrr:
 

·
Moderator
Joined
·
1,536 Posts
1) Sounds like a vacuum problem. I'm not an expert in GM's HVAC system, but I can tell that it uses engine vacuum to operate a lot of the controls. Most of the time, they put a vacuum reservoir with a one way valve on it to "store" vacuum for the HVAC system, even if engine vacuum drops off (like it would when accelerating from a stop). When that one way valve gets stuck open, then the system will temporarily revert to its "default" until engine vacuum recovers.

2) CV joints? Wheel bearing?

3) That just plain sucks.
 

·
Super Moderator
Joined
·
3,377 Posts
I can believe someone stole the receiver off of your truck. I was looking for a suburban online, and a used car lot that was selling a 4x4 sub had to add a post on the listing stating that the front driveshaft was stolen from under the truck while it was sitting on the lot.... go figure... as for your wind problem, it may be something like the rubber boot around the steering column letting wind through, and when it hits 20mph, the boot gets jammed in a position that it doesn't let any more air in.
 

·
Registered
Joined
·
2,428 Posts
1. Check the TPS, at WOT, the AC cuts out.
2. Dunno
3. Receivers are $$, and thieves find them an easy deal. My friend had a lock on his and they took it anyway. The latest rage around here for the smash and grab artists are the 3rd row seats out of SUV's. Smash the rear window, open the door grab the seat and you can sell it on eBay or craigslist for an easy $300 - $700 depending on the SUV. No serial numbers so they are impossible to trace. Local PD's have started etching programs for 3rd row seats. Be warned mark yours now.
 

·
Registered
Joined
·
2 Posts
This is Just well post, i love..!

Very happy to see your article, I very much to like and agree with your point of view. Thank you for sharing. At the same time,i love best pram very much .Welcome to look at my website and blog articles.Hope we can become good friends, and exchange and to help each other! Thanks!!
 
1 - 5 of 5 Posts
Top