GM Truck Club Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
225 Posts
Discussion Starter #1
I have a new glitch, when I lock my sub about 5 minutes alter the interior lights go on. Dealer say the light module is the likely fault. The sub is a 97 with all the electric goodies, where is the light module and is it an easy change out.

Phil
 

·
Registered
Joined
·
225 Posts
Discussion Starter #3
I am in tears!!! Two weeks and no one knows where the light module is located and if it is an easy change out????
 

·
Premium Member
Joined
·
4,886 Posts
huh, anyone? I couldn't find much on "light module", but it's probably called something else? If it is a true light module is probably kept with the PCM/ECM area, but I had seem them kept near the bumper too. Try calling your local auto parts store and seeing what they say it costs and it they have a diagram.
 

·
Registered
Joined
·
533 Posts
proabably cause no body chimed in due to lack of information

no other specs included :)
 

·
Registered
Joined
·
225 Posts
Discussion Starter #6
Steve I may not be calling it the right name, the problem is when I lock the truck the interior light delay works like it should shuts the light off in about 30 seconds. Problem is about 10 minutes later the interior lights come back on and kills the battery by morning. For now I am using the dome over ride so the battery does not go dead, I ask my local service guy what it might be and wa told it needed a light module. If I can get more info I can probably do the change out myself.

Phil
 

·
Registered
Joined
·
533 Posts
I would say its one of the door sensors not connecting properly when closed.

Did you check to see if they need to be cleaned cause it sounds like that when u close the doors and lock ..few minutes later the light goes back on like ajar door .
 

·
Registered
Joined
·
225 Posts
Discussion Starter #8
I would say its one of the door sensors not connecting properly when closed.

Did you check to see if they need to be cleaned cause it sounds like that when u close the doors and lock ..few minutes later the light goes back on like ajar door .
Thanks for your tip, I sanded the barn door sensors and WaLa problem solved!

Thanks!

Phil
 
1 - 8 of 8 Posts
Top