GM Truck Club Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
My Dad owns a '96 GMC Sierra with a '99 350 and rebuilt trans. The engine has about 70k miles on it, and the truck has a new battery. The truck starts up every time very easily. However, after put in drive, when you step on the gas the truck wants to die out and stall unless you let off on the gas. After the initial take off and the truck gets underway, it no longer does this. If you park and restart while the engine is warm it does not do this. Only seems to be when cold. He tells me that the voltage gauge seems to be a little wacky, but I doubt that an alternator could be causing this. Anyone have any similar issues? Any things we should try? Fuel filter? Please help. Any help is appreciated.

Thanks in advance,
Mike W
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
It was a rebuilt '99 from what I know. Probably from a crashed Silverado or Sierra. The previous owner put it in and rebuilt the trans. It has been great for the 40k or so that my Dad has put on it.
Oh yeah, and he just had the fuel pump replaced, too. He took it in because it wouldn't start 100% of the time (unusual), and the shop cited the fuel pump as the problem and replaced it. Anyone else have ideas? I thought the fuel filter should be replaced just in case.

MW
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top