GM Truck Club Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hello to All from Texas. I'm new to this forum, but not that new to forums in general. I participate regularly in RV forums (3), Kayak fishing forums, and once in a while in Zune, DSL, and Taurus forms. We inherited a 99 Suburban that was owned by my FIL (but only for 6 mos) when he passed away 8 years ago. We jokingly refer it as "haunted" because we are having intermitant problems starting the Sub - we THINK it is related to the "Pass-lock II" security system. I searched for, and found this forum this morning, at least initially, to find out if others are having similar problems and I hope to find a solution to this problem. I'll do a seach and see what I can find. Thanks for letting me join.
 

·
Premium Member
Joined
·
4,886 Posts
:sign0016:

Hi & welcome to the forum.

Hopefully someone on here can help you out with your issues. Passlock ... or haunting. ;-)
 

·
Premium Member
Joined
·
1,101 Posts
Welcome to the site. From my understandings, the GM trucks did not use the passlock system until the 07 models, it was only used in the cars. Talk to someone at the dealer parts counter to verify this.

What sort of problems are you having with it? Maybe someone here has gone through something similar and can shed some light.

Oh, and what part of Texas are you in?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
From my understandings, the GM trucks did not use the passlock system until the 07 models, it was only used in the cars.

Oh, and what part of Texas are you in?
Well ... my owners manual says I have it. I wish it didn't. I will disable it, if I can figure out how. All I've ever gotten from a dealer is: "Bring it in an we'll look at it". I swear if the durn thing burned to the ground and was just a pile of ashes, I'd get the exact same response. Oh ... I live in WNW Houston and escaped from the frozen Motor City area 30 some years ago. Thanks for the welcome.
 

·
Registered
Joined
·
126 Posts
Welcome to the club!!
 

·
Registered
Joined
·
2,966 Posts
Welcome. Lets hear some more about what its doing. :neutral:
 

·
Registered
Joined
·
4,151 Posts
:great:Welcome to the site!
 

·
Premium Member
Joined
·
1,101 Posts
Sorry for the misinformation, I was thinking of the keys with the resistors in them, not the system itself. Here is a website that lets you bypass the system. Hope it works for you.

http://members.tripod.com/~alarmtek/VATS.html
 

·
Registered
Joined
·
19 Posts
Discussion Starter #11 (Edited)
Welcome. Lets hear some more about what its doing. :neutral:
About a year and a half ago we started having intermittent problems starting it. It cranks fine, starts to fire, then dies. My mechanic has checked the codes and says that something is wrong with the "Passlock II" factory installed security system It thinks the car is being stolen so it cuts off the fuel. What has worked a few times is letting it sit for at least an hour, then it will start without problem. Hunting around on the net, I have found some info that indicates we are not alone in having this problem, and some have spent over $1000 in replacing ignition switches, computers, "Passlock control modules", etc without fixing the problem. I'd be perfectly happy if I could bypass this Passlock system - which I know would leave the vehicle "unprotected" - I just wish that it could be depended on to start.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #12
Other than the "Welcomes", would the "haunted or Passlock" part of this be more appropriately posted in the "Audio, Video & Electronics" area? Or somewhere else? Some forums have strict rules about double-posting, and I don't wish to run afoul of the moderators.
 
1 - 13 of 13 Posts
Top