GM Truck Club Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
first post

i have a 96 yukon with the 350 vortec
now i am really stubborn, and refuse to pay anyone to fix anything i can do myself, thats why i havnt taken it in anywhere yet

so on my obdII reader, it says low voltage from 2 of teh O2 sensors, ive replaced all 4 of the sensors, so they should be reading correctly

i think its a catalytic converter. but this is my tow truck, and i dont want to dump money into something that isnt broken anymore than i already have

ive gotta say also that i live @5000 ft and work @ 7000 ft elevation

now, in the late afternoon, for some reason it seems to work fine, but when i go to work in the morning, sometimes it wont go over 35mph up hills

it will only accelerate at barely any throttle, which leads me to believe that the ECU is running in open loop 'limp home' mode

i just dumped some seafoam in my fuel tank before i filled up and since then, the engine stutters some times

also, if its at WOT, the tach juggles in about a 500rpm increment (like between 1500 &2000 for example

my next steps are to do the oil and intake with seafoam, and get some junkyard catalytic converters...

this sound like anything else to anyone? im getting irritated, this vehicle isnt supposed to be a project, thats what my cars are for

CJ
 

·
Premium Member
Joined
·
4,886 Posts
Ahh, another one of us that doesn't want to pay for something that we can do ourselves! :)

Where do you get a junkyard catalytic converter at? What state? I've never been able to get a boneyard to tell one to me.
 

·
Premium Member
Joined
·
4,886 Posts
,... how many miles on that engine, BTW?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
130k miles
any pick n pull? the full service ones probably wont sell the cats (honestly i havnt bought them yet, i dont know for sure that i can?) but the junkyards are in nevada

i just remembered its been over 10k miles since i changed my air filter too, so thats on the list now too

im trying to just deal with it and spend as little money now as possible, as i may have gotten a great deal on another fullsize, to be my new towtruck. but pre ODBII and standard transmission (i tend to get drowsy with automatics) I hate OBD2 vehichles, especially as i live in california for now

CJ

my vehicles:
88 nissan silvia rebuild onto USDM legal chasis project
83 toyota ae86 corolla GTS conversion
96 yukon
04 hyundai santa fe (wifes)
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
k, i seafoamed it with 2 bottles (1/3 in fuel, 1/2 in oil, the rest of that bottle, and the other bottle in the intake thru the brake booster)
and changed the oil, put a little hole in teh air filter to get some more flow until i can get a new one

it only tripped a code twice on the way to work (low O2 sensor voltage both times, one had one code, the second time it had 2 sensors low voltage) but i erased them and it kept rolling, managed to do about 60 the whole way to work, couldnt do much more tho

before i seafoamed, if in park and you go to WOT, it would do that bog and bounce between a 500 rpm increment

now if you go to 1/2 throttle, it will rev to redline and sounds healthy, but @WOT it makes some kind of deep noise and stays exactly @3k rpm .. im investigating the noise now
 
1 - 6 of 6 Posts
Top