GM Truck Club Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1 (Edited)
Hi well the more I work on this 91 silverado 305sbc the more things are going wrong. I replaced the control module, plugs. magnetic pick up, rotor & cap now the dam thing wont start. There is no spark, & no spark from the coil, I held the coil wire above the cap terminal and nothing, hooked up a spare plug and no spark there. I used a test light and there is power from the plug that hooks up to the coil and I even checked the power leaving the coil going into the distributor and there was power there. I cranked the engine over and there was power to the coil lead while cranking but still nothing from the coil. So I just about ready to give up and take it to a mechanic maybe he can see something Im missing, anyone had this problem? Before I changed the cap rotor ignition module and magnetic pick up it at least would start now no spark. Help!!!!!!
 

·
Registered
Joined
·
7,291 Posts
Do you know if any of the replacement parts where made in China? I've seen that crap drive guys crazy after installing.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
I dont know but what I did was pull the distrib and put in a new mag coil pick up, put everything back together and now no fire. So would something I did cause the coil to have no spark to the distrib. Also I put in a new ignition contol module could this be defective? almost ready to give up on this, thanks.
 

·
Registered
Joined
·
20 Posts
its highly possible to pick up new parts that are defective. its happened to me way to many times to count. coils as far as my exp with them ive had new ones crap on me all the time lol. try that way first before you take to a mechanic cuz ignition work at a shop will cost an arm and a leg. good luck
 
1 - 4 of 4 Posts
Top