GM Truck Club Forum banner
1 - 6 of 6 Posts

·
Registered
1988 k1500
Joined
·
13 Posts
Discussion Starter · #1 ·
Hello i have a 1988 k1500 , recently i was at a red light when my oil gauge was on the first like on the gauge then dropped to 0 and made the check gauges light turn on , but then quickly it went back up to the first like again. Any help i would really appreciate it. Thanks
 

·
Registered
‘01 Silverado 2500HD 8.1/Allison 5sp xcab long bed
Joined
·
3,787 Posts
First thing that comes to mind is a new oil pressure sensor is needed.
 

·
Registered
2000 Silverado Z71 4x4 5.3L 460k+ miles w/ GM rebuilt motor and trans
Joined
·
1,435 Posts
Stupid question...Have to ask. Did you verify you have the appropriate amount of oil in your vehicle?

I was running down the interstate doing things with my mother's truck I shouldn't when the oil pressure fell out the bottom. After a panic-stricken drive to the first exit and parking in a deserted parking lot, I crawled around looking for a hole or something, thinking I had thrown a rod or blown something out the side. Turns out ALL the oil had leaked out of the truck after an oil change (loose filter) and it just needed a gallon of oil from the convenience store...
 

·
Registered
98 gmc k1500 5.7
Joined
·
556 Posts
wrong sensor , check make sure its the correct sensor for your truck , count the wires and the prongs in sensor, is it a gm sensor, some aftermarkets are bad in the box, i just posted about same issue on the Silverado / sierra forum
 
1 - 6 of 6 Posts
Top