GM Truck Club Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
So here is the back story we have a 2006 chevy suburban and back in December I pulled the radio out and it then quit working when I put it back in (after narket radio) so I messed with the wire harness connected some wires and it worked again just fine. Fast forward to February. I parked it and everything was fine, next day the radio wouldn't work, also the power locks, 4 wheel drive switch, and just some of the gages and the battery light was on, took it to my mechanic and he checked the alternator and the battery and all the electrical wires that he could see. Then gave up, then I took it to a guy at our church that works on cars and he rechecked the battery and alternator and switched out the instrument panel and replace the ignition switch and still nothing. He said if you hold the ignition switch all the way over it will work for a few minutes at best and then instrument panel and 4-wheel drive switch well quit working again, this happened with the old ignition switch and the new ignition switch. Help [email protected]
 

·
Registered
Joined
·
489 Posts
If this all started with a radio install I’d take it to a BestBuy and have their Geek Squad people look over the wiring. Some Geek Squad radio installers are better than others. So happens near me they’re quite good.
 

·
Registered
Joined
·
15,160 Posts
I agree, there is a problem with the radio wiring.
You may now have 2, or more problems; but start with the radio wiring
 
1 - 3 of 3 Posts
Top