GM Truck Club Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I cleaned the MAF sensor, but the engine light came back on after a few miles. I was wondering what to look for next....TPS?.....injector?
 

·
Registered
Joined
·
5,772 Posts
POST YOUR ENGINE AND TRUCK MODEL YEAR ...
BANK 1 SENSOR 2 IS driver side rear of the cat converter. so most times the wiring on driver side gets damaged. replace the sensor do not
mess with the wires... or you can swap the pass side to the driver side ..
when you remove the O2 sensor wire brush the O2 sensor ports so they are clean... check for any manifold/pipe leaks bolts rusted off ... just this 138 code ....138 says rich only on the driver side .. after the cat converter many times the old O2 sensor do fail 120K-140K miles...

maf/injector/fuel regulator will throw other codes bank 1 sensor 1 codes ..
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks for the comeback, the truck is a 2011 2500hd with a 6.0l vortec. I put a new sensor in on the driverside after the converter; however the problem is still there.
 

·
Registered
Joined
·
13,464 Posts
This is not intended to be a smart ass question; but it begs to be asked!
Did you clear the code(s) after changing the sensor?
 

·
Registered
Joined
·
5,772 Posts
Thanks for the comeback, the truck is a 2011 2500hd with a 6.0l vortec. I put a new sensor in on the driverside after the converter; however the problem is still there.
you only have the P0138 code ? use a scan tool again >>>.
 

·
Registered
Joined
·
5,772 Posts
Thanks for the comeback, the truck is a 2011 2500hd with a 6.0l vortec. I put a new sensor in on the driverside after the converter; however the problem is still there.
you only have the P0138 code ? use a scan tool again >>>.
check for exhaust leaks and wiring / connector O2 sensor damage. another thing could be the cat converter or the PCM connectors . check all the PCM connectors for any corrosion . look very carefully on the pins of the PCM connectors... remove the negative battery ground when checking the wiring / connectors..
 
1 - 6 of 6 Posts
Top