GM Truck Club Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi,

I have a 03 Silverado LS. It came stocked with the Stardard RDS Radio/CD player. A couple days ago the sound stopped working on the radio but I can still see the display (including station and song info).

This happened a few months ago and was getting ready to take it to the shop when one day the battery was dead. After jumping the battery everything worked fine, including sound from the radio.

Has this ever happened to anyone or does anyone have any idea what could be causing this?
 

·
Registered
Joined
·
2 Posts
I don't know if this is to late, but I have had the same problem with my 2003 HD Crew Cab. Bose radio system. First radio problem, no audio output, display is fine. Two days later, truck won't start but radio plays. Towed to dealership. Diagnosis "shorted resistor in blower control circuit GM part #89018597" part replaced under warranty. One year later while on vacation out of state, radio quits, go to local dealer he looks up history on his computer,orders in same part on my request. Next day battery dead, towed in. Replaced part charged battery on my way.

I have seen on other forums where people with the same problem have payed big bucks to change out the radio, and/or the battery and alternator.

Good Luck JJ
 

·
Registered
Joined
·
404 Posts
Resistor in blower control circuit? That's a new one to me. I guess vehicles electronics are so interrelated these days that it's possible.

Have you has anymore problems JJ?
 

·
Registered
Joined
·
2 Posts
I haven't had a problem since, but it's only been a little over 2 months. I intend to spend a lot of time at the dealership asking questions. At this point i'm just collecting evidence to support my claim. I want to know IF there is a link between the AMP circuit and the blower control circuit. For all I know they may just be pulling answers out of thin air and it was a lucky guess. FYI the control circuit is located in the blower housing under the glove compartment. JJ
 

·
Premium Member
Joined
·
4,886 Posts
Sometimes these things run through a model year, bad subcontractor on a component, etc. I'd be interested in seeing if other people from this year (+/- 1 year) have a similar issue.
 

·
Premium Member
Joined
·
4,886 Posts
Keep us updated.
 

·
Registered
Joined
·
56 Posts
gm had a problem with the bose system atleast in my 03 the radio would display but no sound the fix was to replace the external amp hope this helps
black03silverado
8)
 

·
Registered
Joined
·
2 Posts
Discussion Starter #8
It hasn't happened since I started this string, but I do carry a jumper at all times.

On my truck all I have is the standard stock Radio/CD not a Bose, but I would guess most of the supporting components are the same, but I and taking notes in case it happens again.
 

·
Registered
Joined
·
4 Posts
Well I don't have any radio issues but I am having problems with the heater blower resistor.
Mine burned up and I replaced it but i still can't get the blower to work.
 
1 - 9 of 9 Posts
Top