GM Truck Club Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
2,959 Posts
Well here I go again, I have maybe a problem and I'd like to ask you guy's if it is normal.

When I enter 4 wheel Hi setting and turn my wheels to almost max lock my '06 TB jerks and feels like the traction control being applied to the front wheels. it is hard to explain and is only noticed on 4Wheel Hi and only when I cut the wheels sharp, to like enter a parking spot.

Does this make sense, and has anyone felt the same loss of power and jerky almost like the brakes are being applied feeling in 4W Hi.


DR.Z

I see I put this in the wrong heading it is a TrailBlazer sorry.......
No prob Dr Z. Patrick or Steve will see it and move it as necessary.
Anyway are you trying to put in 4hi on dry pavement?
 

· Registered
Joined
·
2,959 Posts
I think I'm going to assume it was maybe wet or something like that.
My '04 does the same thing and I know exactly what your going thru.
These are rather wimpy 4wd set up and don't take kindly to moving the damn wheel at all(in 4hi). I leave mine in auto 4wd if I'm in snow or something it seems to do a better job anyway. I miss the old days when you had a front axel and you could pull the lever back in 4hi. A nice clunk and it would come on with authourity. Hopefully I've answered your question cuz more than likely theres nothing wrong wih your truck.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top