GM Truck Club Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys I’m new to the truck stuff. I installed the lift kit myself and everything went smooth. It’s a 16 Sierra 4wd installed 5 inch knuckle from rough country. After install I waited for my 2 inch spacers to come in before the alignment so I drove the truck to work to see any shaking on highway. Got the wheel alignment yesterday and I’m on the highway and it starts vibrating and my abs and stability light comes on. I turn on and off and it goes away. It only comes on around 70+. It never did this until I got a alignment. Took it back and they said it’s because I lifted the truck, wheels are off balance, or my wheel spacers. I’m still on stock 20’s. So now my other problem is when In 4wd it sounds like it’s grunting and not sounding like it should. I’m not sure what to do or what to look for. Any help would be appreciated. Thanks!
 

·
Registered
Joined
·
2 Posts
Hey guys I’m new to the truck stuff. I installed the lift kit myself and everything went smooth. It’s a 16 Sierra 4wd installed 5 inch knuckle from rough country. After install I waited for my 2 inch spacers to come in before the alignment so I drove the truck to work to see any shaking on highway. Got the wheel alignment yesterday and I’m on the highway and it starts vibrating and my abs and omegle stability light comes on. I turn on and off and it goes away. It only comes on around 70+. It never did this until I got a alignment. Took it back and they said it’s because I lifted the truck, wheels are off balance, or my wheel spacers. I’m still on stock 20’s. So now my other problem is when In 4wd it sounds like it’s grunting and not sounding like it should. I’m not sure what to do or what to look for. Any help would be appreciated. Thanks!

issue got solved!!
 

·
Registered
‘01 Silverado 2500HD 8.1/Allison 5sp xcab long bed
Joined
·
3,748 Posts
What was the solution?
 

·
Registered
Joined
·
16,031 Posts
What was the solution?
Greg, did you notice the same post from 2 different posters?

Edit:
Oooops, see the 2nd guy was just replying to the 1st post.

2nd edit.
He's saying it was fixed.......hmmmmm, 2 different guys, 2 different countries.
 

·
Registered
‘01 Silverado 2500HD 8.1/Allison 5sp xcab long bed
Joined
·
3,748 Posts
Yeah, a little bit strange there.
 
1 - 5 of 5 Posts
Top