GM Truck Club Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
First of all, I would like to say how much I have enjoyed reading this fourm. This will be my first post here. I have been doing some searching and can't seem to find where anyone else has had a problem quite like this one.

I have just purchased a 02 suburban (a replacement for my 89 diesel suburban) and I am having a few problems with it, most of which center around the front passenger door.

The window switch on that door does not work, the window will go up and down from the drivers switch but not from the passenger switch.

The power door lock actuator on that side doesn't work. The door lock switch on that door will work the other locks, but the actuator on that door never moves. (I have taken the door panel off and found no loose wires, also when I put a meter on the wires going to the actuator there doesn't seem to be any power when the button is pushed)

The truck doesn't know if that door is open or closed. (ie. the dome light never comes on and the radio never shuts off) I really wish someone would clue me in to where the sensor is for that.

I don't know if I have one thing causing all of these problems or if I have three different problems at the same time.

My other issue involves the rear AC. The truck has the smart climate control, the front works fine, the back fan never comes on.

I know this is a lot to ask for a first post, but I really appreciate any help, I'm starting to go crazy here trying to figure this stuff out.

Eric
 

·
Registered
Joined
·
2,630 Posts
It sounds like you have two different problems.
Your window switch is bad, and you have possibly a broken lead in the door wire loom.

I would trace the wire back into the loom, and as close to the vehicle body as possible. Sometimes the wires in the loom that lead from the body to the door get fatigued from the constant bending of the door opening, and closing, and eventually break. Check for voltage there when using the switch. This could also be the problem with the window as well, but I still think you have two distinct problems here.
 
1 - 2 of 2 Posts
Top