GM Truck Club Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 · (Edited)
Hello,

I have a new problem troubling my 2005 Chevy Silverado 5.3L. There has been a check engine light for a few weeks, but the truck has been driving fine so I wasn't too worried. Yesterday morning my radiator fans were running even though the truck hadn't been driven since the afternoon before and the engine was cool.

I ran the codes and got 3: P0480 - Fan Control Relay 1, P0332 - Knock Sensor, and B0103 - Unknown https://trackeasy.fun/usps/ https://showbox.tools/.

I read up a little and found that some people had found that the blue ECM plug had water in it causing corrosion.

I pulled the plug and may have found a drop of water. It was hard to tell because it had been raining while my hood was up. I used a heat gun to dry up the plug and added a little dielectric grease. I put it back together and charged the battery and this morning, the same thing...the fan was running. I stopped by the auto parts store and bought a relay and will put it in tonight. Hopefully this is the fix, but since I can stop the fan temporarily by starting and stopping the motor, I doubt it.

It seems this is a fairly common problem, and I followed recommendations I found. I was hoping I could get some good advice and get this resolved.

Lincon.
 

·
Registered
Joined
·
6,092 Posts
I now that on the engine temp sensor with electric fans the fans will turn on when the connector is corroded and will not connect correctly.. fans turn on with many controller components ..tricky..

replace the fan relay or wiring issues temp sensor/PCM ..
 
1 - 2 of 2 Posts
Top