GM Truck Club Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have an '05 Ext Cab Silverado Z-71 that I just bought about a month ago. The other day I was hauling a load of landscaping block from Lowes (about 1500 lbs worth) and I noticed a pulsing squeak that would become more frequent the faster I went. It only happens while accelerating and not when cruising. Almost as if the exhaust is rubbing on something when the engine is under load and torqued over to one side. I figured that maybe with the load in the bed that maybe an exhaust hanger or something was rubbing on the under carriage and that once I unloaded the truck it would go away. Well, it didn't. Now it's getting louder by the day. I climbed under neath to take a look but couldn't find anything. I've pushed and pulled on about everything under the truck and can't seem to replicate the sound. Any ideas before I go to the dealer?
 

·
Registered
Joined
·
225 Posts
Does the sound has a ringing squeakto it? Thinking maybe a U joint, noisey going up but quiet at speed. With the drive shaft working at a different angle under a higher load is makes me think U joint.

Phil
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
You are exactly right. I took it to the dealer on Friday and they replaced both U-joints under warranty. 35k miles seemed a little early for U-joint replacement though.

Thanks for the input!

Steve
 

·
Registered
Joined
·
225 Posts
You are exactly right. I took it to the dealer on Friday and they replaced both U-joints under warranty. 35k miles seemed a little early for U-joint replacement though.

Thanks for the input!

Steve
The former owner may have bathed them a few times, when I di a lot of woods running I would kill a set a lot sooner. Glad I have a good tip for you!

Phil
 
1 - 4 of 4 Posts
Top